aspose file tools*
The moose likes JSF and the fly likes Facelets not working on Godaddy Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSF
Bookmark "Facelets not working on Godaddy" Watch "Facelets not working on Godaddy" New topic
Author

Facelets not working on Godaddy

Casey Kcins
Greenhorn

Joined: Mar 12, 2007
Posts: 16
Hi everybody!
I'm attempting to deploy a JSF/Facelets web application to my GoDaddy shared hosting account, but it doesn't seem to be working...
My calls to technical support provide no assistance.
I was wondering if anyone here has had any luck deploying to GoDaddy?
It seems to me that Tomcat isn't serving the files.

I tried the default servlet-mapping for Facelets...
http://www.servicesoftheweb.com/index.xhtml

I also tried changing the extention just in case apache was grabbing it...
http://www.servicesoftheweb.com/index.do

Still no luck...

Ideas?

Thanks!

-- Casey Kcins
[ June 19, 2007: Message edited by: Casey Kcins ]
Abiodun Adisa
Ranch Hand

Joined: Jan 17, 2002
Posts: 495
I have deployed to GoDaddy but then i used a virtual dedicated Server. I installed Apache Tomcat and copied the JSF libs to the Apache Lib Folder. Everything then worked perfectly
Chris Shellenbarger
Greenhorn

Joined: Mar 14, 2006
Posts: 3
The last time I looked into deploying on a shared hosting account at GoDaddy it looked like you had to place the file in a staging area and they would deploy from that staging area once a night at a certain time. If you are using virtual/dedicated server it should be just like normal.

Also, I don't think that their Tomcat version is up to date enough to run Java Server Faces.
[ June 19, 2007: Message edited by: Chris Shellenbarger ]
Casey Kcins
Greenhorn

Joined: Mar 12, 2007
Posts: 16
GoDaddy restars Tomcat every night at 1am, so I guess if new code was deployed, it wouldn't go into effect until then.

GoDaddy uses tomcat version 5.0.27. I looked and looked and couldn't figure out which version of tomcat JSF & Facelets requires. So I downloaded v5.0.28 from Apache (they didn't have .27 available for download), and I deployed my app to that version, and it works fine. So I'm fairly certain GoDaddy's version can handle it.

Also as a test, I created a simple jsp file, and uploaded it. That also doesn't work.

The error I'm getting is tomcat's 404.



I called GoDaddy, and they said it could be a lot of things, and I should "ask Tomcat" to make sure everything's okay with the app.

Any idea why I'd be getting the 404?

Thanks for the help!

-- Casey Kcins
Demian Seiler
Greenhorn

Joined: Oct 20, 2006
Posts: 11
I know this is a fairly old post, but I am working on this same scenario.

Make sure that your jsp/servlets are enabled on your hosting account. By default they are disabled and I think after I submitted to have it enabled it was done within a day. Thus far I have been able to deploy a JSP app and a JSF 1.1 app successfully. I am working on getting facelets working up there now. As far as Tomcat 5.0.27 you have to dig a little to find it. Try this link to download it.

Apache Tomcat 5.0.27 Archive Directory

I will try to repost if I get facelets working.

Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16012
    
  19

http://faq.javaranch.com/java/DontWakeTheZombies

Chances are, everyone originally involved isn't even working for the same employers they did back then. I'm sure that they either resolved or abandoned the problem by now.


Customer surveys are for companies who didn't pay proper attention to begin with.
ushernut guan
Greenhorn

Joined: Oct 10, 2009
Posts: 2
I also got this problem, and I found godaddy using tomcat 5.0.27 actually does not support JSF. I have tried like this, create a hello world JSF project and upload to my share account hosting. It doesn't work.

This is what I observed so far.


http://www.simtak.com
ushernut guan
Greenhorn

Joined: Oct 10, 2009
Posts: 2
ok, I got response from godaddy. They don't support JSF for linux shared hosting.
This is such a bad news.........
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Facelets not working on Godaddy