File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JSF and the fly likes trying to use tomahawk and rich faces jar?    Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSF
Bookmark "trying to use tomahawk and rich faces jar?    " Watch "trying to use tomahawk and rich faces jar?    " New topic
Author

trying to use tomahawk and rich faces jar?

Gopu Akraju
Ranch Hand

Joined: Jan 13, 2008
Posts: 242
I tried a very simple example to know how to use menu group. These are the following steps:
1. I opened a web application using Netbeans using JSF as framework.
2. When I run my application, it worked and welcomeJSF page was displayed.
3. Then I wanted to a try a sample program. Hence I modified welcomeJSF page as below:

<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>
<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
<%@ taglib uri="http://myfaces.apache.org/tomahawk" prefix="t" %>
<%@ taglib uri="http://richfaces.org/rich" prefix="rich" %>


<f:subview id="menuSubView">
<h:form>
<t:panelGrid columns="1" width="50">
<rich:dropDownMenu value="Menu" direction="bottom-right">
<rich:menuItem value="Home" action="home"/>
<rich:menuSeparator id="menuSeparator1"/>

<rich:menuGroup value="test">
<rich:menuGroup value="Library ">
<rich:menuItem action="regNewLibrary" value="new"/>
<rich:menuItem action="regEditLibrary" value="edit"/>
</rich:menuGroup>
<rich:menuGroup value="Sample ">
<rich:menuItem action="regNewSample" value="new"/>
<rich:menuItem action="regEditSample" value="edit"/>
</rich:menuGroup>
<rich:menuGroup value="search ">
<rich:menuItem action="regSearchLibrary" value="library"/>
<rich:menuItem action="regSearchSample" value="sample"/>
</rich:menuGroup>
</rich:menuGroup>
<rich:menuSeparator id="menuSeparator2"/>

<rich:menuGroup value="test2 ">
<rich:menuItem action="testSelectLibrary" value="Load Library"/>
<rich:menuItem action="testSeqRequest" value="Seq Request"/>
</rich:menuGroup>
<rich:menuSeparator id="menuSeparator3"/>

<rich:menuItem value="Exit" action=" testing"/>

</rich:dropDownMenu>
</t:panelGrid>
</h:form>
</f:subview>




4. I added tomahawk-1.1.6.jar, richfaces-api-3.1.0.jar, richfaces-impl-3.1.0.jar, richfaces-ui-3.1.0.jar into libraries.
5. When I run my application, I get an error report as below:


type Status report

message /test1/

description The requested resource (/test1/) is not available.




Can anyone tell me what went wrong?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: trying to use tomahawk and rich faces jar?