Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

ejb on Weblogic7

 
sjava
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,
I am deploying a simple webservice (with an entity bean) on weblogic 7 from my own directory(for eg :- C:/test) .
To compile ejb classes and generate ejb-jar , ear files , I am using ANT . While compiling the ejb classe , i am
encountering the following error :
ejb:
[mkdir] Created dir: C:\Test\build
[mkdir] Created dir: C:\Test\build\META-INF
[copy] Copying 5 files to C:\Test\build\META-INF
[javac] Compiling 3 source files to C:\Test\build
[jar] Building jar: C:\Test\HelloEntity.jar
[java]
[java] ERROR: Error from ejbc: null
[java]
[java] java.lang.NullPointerException
[java] at weblogic.ejb20.deployer.CompositeMBeanDescriptor.getPersisten
ceUseIdentifier(CompositeMBeanDescriptor.java:1389)
[java]
[java] ERROR: ejbc found errors
[java]
[java] at weblogic.ejbc20.formatErrorsInCollection(ejbc20.java:578)
[java] at weblogic.ejbc20.runBody(ejbc20.java:467)
[java] at weblogic.utils.compiler.Tool.run(Tool.java:126)
[java] at weblogic.ejbc.main(ejbc.java:21)
[java] Exception in thread "main"
[java] Java Result: 1
Could not read Web Service deployment descriptor
I have set the classpath and it is pointing to \server\bin and the ANT which in run points to \server\lib which has
weblogic.jar .
Am i going wrong somewhere in setting the path . Pls help
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic