File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Web Services and the fly likes Webservice on WAS 4.0.5 under Solaris Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Webservice on WAS 4.0.5 under Solaris" Watch "Webservice on WAS 4.0.5 under Solaris" New topic
Author

Webservice on WAS 4.0.5 under Solaris

Jan-Dirk Heimrich
Greenhorn

Joined: Jul 28, 2003
Posts: 2
Hi,
we wrote/gernate a Webservice with WSAD 5. When installing the EAR on
WAS 4.0.5 Servers under W2K everything seems fine but when installing
the same EAR on WAS 4.0.5 under Solaris the Webservice isn't
registered. The generated admin-pages says there is no Webservice
deployed. I think it's a JDK or Xerces problem but don't realy know.
Perhaps someone can help. Thanks so long.
Jan-Dirk Heimrich
Greenhorn

Joined: Jul 28, 2003
Posts: 2
In addition to the first post I have determined a problem in my serverlogs.
It say's that ist can't read the DeployedServices.ds. This file exists anywhere on my solaris-server. But also not on the W2k servers. It is possible that I have to write it on my own with all values out of my WSAD-generated deployment descriptor file called dds.xml ?
JeanLouis Marechaux
Ranch Hand

Joined: Nov 12, 2001
Posts: 906
Hi Jan-Dirk,
I think you would rather post this kind of question in the IBM WebSphere Forum
I'm sure Kyle (Brown) will help you there
[ July 28, 2003: Message edited by: Jean-Louis Marechaux ]

/ JeanLouis<br /><i>"software development has been, is, and will remain fundamentally hard" (Grady Booch)</i><br /> <br />Take a look at <a href="http://www.epfwiki.net/wikis/openup/" target="_blank" rel="nofollow">Agile OpenUP</a> in the Eclipse community
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Webservice on WAS 4.0.5 under Solaris
 
Similar Threads
Deploy multiple webapps in jboss
JSPs don't see EJBs
Servicegen on windows and solaris
Migration from WAS4 to WAS 5
Solaris 9