Meaningless Drivel is fun!*
The moose likes Web Services and the fly likes JAXB sample in the JWSDP1.3 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "JAXB sample in the JWSDP1.3" Watch "JAXB sample in the JWSDP1.3" New topic
Author

JAXB sample in the JWSDP1.3

Tong Chen
Ranch Hand

Joined: Apr 26, 2002
Posts: 1011
I tried to use the JWSDP1.3 and tried to get the first example unmarshal-read running.
Used the ant to build it without problem.
Then I saw a Main.class was created under c:\jwsdp-1.3\jaxb\samples\unmarshal-read

Then under the same place, I tried to type in the commandline:
java Main
Then got the following error:
Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/JAXBException
Anyone gets any ideas?
Thanks!


Tong Chen (Seattle USA)<br />SCJP,SCWCD,SCDJWS,IBM XML,MCP.NET,MCAD.NET,MCSD.NET
Greg T Robertson
Ranch Hand

Joined: Nov 18, 2003
Posts: 91
i believe most of the build.xmls in the samples have a task named run as well so do an "ant run" and it should work. otherwise manually place the jaxb libs on your classpath and run them
Tong Chen
Ranch Hand

Joined: Apr 26, 2002
Posts: 1011
I used:
java -classpath C:\jwsdp-1.3\jaxb\lib\*.jar; C:\jwsdp-1.3\jwsdp-shared\lib\*.jar Main
don't work?
Rashmi Tambe
Ranch Hand

Joined: Aug 07, 2001
Posts: 418
try putting individual jar file names in classpath instaed of *.jar.
 
wood burning stoves
 
subject: JAXB sample in the JWSDP1.3
 
Similar Threads
JAXB doubt
Problem with Jaxb marshalling inside EJB
Issue with file component (camel is not consuming files from the folder periodically until ends
New to Web Services and JAXB
JAXB 1.0.2 Unmarshal error, 'unexpected root element'