This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Web Services and the fly likes nullpointer exception when restarting was with a webservice Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "nullpointer exception when restarting was with a webservice" Watch "nullpointer exception when restarting was with a webservice" New topic
Author

nullpointer exception when restarting was with a webservice

Cornelis Hunter
Greenhorn

Joined: Jan 26, 2005
Posts: 2
I've the following issue:

Deployed an EAR with several WAR files in a WSAD testenvironment
WSAD 5.0.1 and testenvironment is WAS version4.
One of the webapplications contains a SOAP application. The application is created with the SOAP wizard of WSAD (RPC/Encoded).
The application works fine, it can be reached by a Delphi client that is generated with help of the created WSDL. However when i try to restart the application it fails.
so:
Stopping and starting the server, no problem
Restarting the EAR, fails
Restarting the other WAR files, no problem
Restarting the specific WAR file, fails.

There is another WAR file, also with a SOAP layer that is created by hand, this one does not fails at a restart. I've checked both the classpath's, manifest file, web.xml, dds.xml, the websphere specific deployement files. But there i could not find any differences.

Does anyone knows this problem (and a solution or cause, i hope!)?
I post this question in the Web Services edge but it probably has no cause related with the web service aspect of the application?


some lines of the console:
[26-1-05 12:00:39:969 CET] 752b038 SystemOut U WebSphere Application Server, Advanced Single Server Edition V4.0
WebSphere Application Server, Advanced Developer Edition V4.0
WebSphere Application Server, Advanced Edition V4.0

[26-1-05 12:00:39:969 CET] 752b038 SystemOut U Runtime Utility Program
[26-1-05 12:00:39:969 CET] 752b038 SystemOut U Copyright (C) IBM Corporation, 1997-2001
[26-1-05 12:00:39:969 CET] 752b038 SystemOut U
[26-1-05 12:00:39:969 CET] 752b038 SystemOut U Restarting applications and modules.
[26-1-05 12:00:39:985 CET] 1931302a ServletEngine A SRVE0170I: Stopping Web Module: CompanyWebService.
[26-1-05 12:00:39:985 CET] 752b038 SystemOut U WSRU0031E: Command Failure: Restart Applications and Modules.
[26-1-05 12:00:39:985 CET] 752b038 SystemOut U WSRU0039E: An exception occurred while processing the method:
[26-1-05 12:00:39:985 CET] 752b038 SystemOut U java.lang.NullPointerException
[26-1-05 12:00:39:985 CET] 752b038 SystemOut U WSRU0051I: Additional information was retrieved:
[26-1-05 12:07:16:735 CET] 549ef02f SystemOut U

thanks, in advance
 
 
subject: nullpointer exception when restarting was with a webservice
 
Similar Threads
Can't start a server with WSAD...
Help-can seem to connect to an AS400 datasource from WSAD test environment
Misterious problem calling remote EJB3 on Websphere 7
Misterious Problem invoking remote EJB3 on WAS 7
nullpointer when restarting webmodule with soap