Win a copy of Learn Spring Security (video course) this week in the Spring forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Server Side AXIS-Web Service Unknown Exception

 
Rr Kumaran
Ranch Hand
Posts: 548
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,


Environment
------------
1. WSAD 5.1.2
2. AXIS 1.2 RC2 on both server and client
3. WebSphere Application Server 5.0
4. custom (de)serializers written replacing axis default (de)serializers both at server side and client side

I have deployed an EJB using WSAD 5.1.2's WebSphere 5.0 Test Environment and exposed it as web service using AXIS 1.2 RC2 on the server side.

I am able to test and run the ejb using WSAD's Universal Test Client but when I write a web service client program that uses AXIS 1.2 RC2 generated stubs I am getting valid soap request and below soap response from the server but no error message in server stack trace.

<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<soapenv:Body>
<soapenv:Fault>
<faultcode>soapenv:Server.userException</faultcode>
<faultstring>org.xml.sax.SAXException: Deserializing parameter 'dce-plane-liste-request-bean': could not find deserializer for type {http://ws.myengine.com/schemas/nec}dce-plane-liste-request-bean</faultstring>
<detail/>
</soapenv:Fault>
</soapenv:Body>
</soapenv:Envelope>


For your information here is my server-config.wsdd on the server side :

<service name="DCEPLWS" provider="java:EJB" style="wrapped" use="literal">
<parameter name="homeInterfaceName" value="<some valid setting>"/>
<parameter name="remoteInterfaceName" value="<some valid setting>"/>
<parameter name="allowedMethods" value="<some valid setting>"/>
<parameter name="className" value="<some valid setting>"/>
<parameter name="beanJndiName" value="<some valid setting>" />
<parameter name="jndiURL" value="iiop://localhost:2809/"/>
<parameter name="jndiContextClass" value="com.ibm.websphere.naming.WsnInitialContextFactory"/>
<parameter name="wsdlPortType" value="<some valid setting>"/>
<parameter name="wsdlServicePort" value="<some valid setting>"/>
<parameter name="wsdlTargetNamespace" value="<some valid setting>"/>
<namespace><some valid setting></namespace>
<typeMapping xmlns:ns="http://ws.mycomp.com/schemas/irscee" qname="ns c-planee-list-request-bean" type="java:com.mycomp.DCPlanListRequestBean" serializer="com.mysd.RamSerializerFactory" deserializer="com.mysd.RamDeserializerFactory" encodingStyle=""></typeMapping>
<typeMapping xmlns:ns="http://ws.mycomp.com/schemas/irscee" qname="ns c-planee-list-data-bean" type="java:com.mycomp.DCPlanListDataBean" serializer="com.mysd.RamSerializerFactory" deserializer="RamDeserializerFactory" encodingStyle=""></typeMapping>
<typeMapping xmlns:ns="http://ws.mycomp.com/wsdl/irscee" qname="ns:MyException" type="java:com.mycomp.MyException" serializer="com.mysd.RamSerializerFactory" deserializer="RamDeserializerFactory" encodingStyle=""></typeMapping>
</service>



I see that all my entries in my above server-config.wsdd file are correct. How do I further debug this problem ?

Can anyone please tell what is this error occurring and how to solve it ?




Thanks & Regards,
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic