aspose file tools*
The moose likes Web Services and the fly likes Unable to load/instantiate axis custom (De)Serializers Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Unable to load/instantiate axis custom (De)Serializers" Watch "Unable to load/instantiate axis custom (De)Serializers" New topic
Author

Unable to load/instantiate axis custom (De)Serializers

Rr Kumaran
Ranch Hand

Joined: Sep 17, 2001
Posts: 548
Hi All,

I have written custom (De)Serializers. Basically I have extended org.apache.axis.encoding.ser.BaseDeserializerFactory for implemenging my custom DeSerializer Factory class and I have implemented below 2 methods in my class :

public MyCustomDeserializerFactory(Class clas, QName qname)
protected Deserializer getGeneralPurpose(String arg0)


I am now using my custom DeSerializer for an ejb web service exposed using AXIS 1.2 RC2 on WebSphere 5.0. I have declared all my configuration details like typeMapping in my server-config.wsdd file but somehow when my service starts up I see error messages on WebSphere like "Unable to create MyCustomDeserializerFactory instance"

Under what scenarios such error appear and I am not understanding when my DeSerializer class is getting instantiated and somehow I feel that my DeSerializer class constructor MyCustomDeserializerFactory(Class clas, QName qname) is not called. I am not sure but just this is a wild guess ...


Please suggest ....



Thanks & Regards,


RR Kumaran
SCJP 1.4
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Unable to load/instantiate axis custom (De)Serializers
 
Similar Threads
Problem with Custom (De)Serializers with AXIS, WebSphere, EJB
Problem in custom axis (De)Serializers
Server does not load custom axis (De)Serializers
Problem with Custom (De)Serializers with AXIS, WebSphere, EJB
Server Side AXIS-Web Service Unknown Exception