Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Soap Envelope not version 1.1

 
jonathan Greens
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi folks,
I am having trouble making webservices calls. I always get a Soap Envelope not version 1.1 fault, what's wrong? thanks
Here is my XML messages:

Request:

<?xml version="1.0" encoding="UTF-8" ?>
+ <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:q0="http://schemas.xmlsoap.org/soap/encoding/" xmlns:q1="http://159.62.245.123:81/cgi-bin/RSService/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <SOAP-ENV:Body>
- <ns0:SearchAndReturnRecords xmlns:ns0="urn:RSSoap" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
<version xsi:type="xsd:string" />
<searchExpression xsi:type="xsd:string">*</searchExpression>
<databaseCount xsi:type="xsd:short">1</databaseCount>
<sortKey xsi:type="xsd:string" />
<maxRecords xsi:type="xsd:long">10</maxRecords>
<databaseArray q0:arrayType="xsd:string[0]" xsi:type="q1:List" />
</ns0:SearchAndReturnRecords>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>


Response:
- <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:SOAPSDK1="http://www.w3.org/2001/XMLSchema" xmlns:SOAPSDK2="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAPSDK3="http://schemas.xmlsoap.org/soap/encoding/">
- <SOAP-ENV:Body SOAP-ENV:encodingStyle="">
- <SOAP-ENV:Fault>
<faultcode>SOAP-ENV:VersionMismatch</faultcode>
<faultstring>Soap Envelope not version 1.1</faultstring>
</SOAP-ENV:Fault>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic