wood burning stoves 2.0*
The moose likes Web Services and the fly likes Does Axis 1.2 require Java 5.0? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Does Axis 1.2 require Java 5.0?" Watch "Does Axis 1.2 require Java 5.0?" New topic
Author

Does Axis 1.2 require Java 5.0?

Henry Wong
author
Sheriff

Joined: Sep 28, 2004
Posts: 18505
    
  40

I am trying to port an application that originally used Axis 1.1 to Axis 1.2. However, the generated code doesn't compile. It looks like some of the code is assigning primatives to wrapper objects.

With Java 5.0, this is not a problem with autoboxing. Unfortunately, I am using Java 1.4.2.

Question. Does Axis 1.2 require Java 5.0? And if it doesn't, am I missing something? Like maybe a parameter to axis-wsdl2java?

This is probably something annoying simple.

Many thanks in advance.
Henry


Books: Java Threads, 3rd Edition, Jini in a Nutshell, and Java Gems (contributor)
Henry Wong
author
Sheriff

Joined: Sep 28, 2004
Posts: 18505
    
  40

Okay... everyone tells me to go with Axis 1.1 -- as it is very stable. I will do this.

But does anyone happen to know if there is a Java 1.5 retriction with Axis 1.2? I would still like to know.

Thanks,
Henry
Balaji Loganathan
author and deputy
Bartender

Joined: Jul 13, 2001
Posts: 3150
Originally posted by Henry Wong:
But does anyone happen to know if there is a Java 1.5 retriction with Axis 1.2? I would still like to know.

No.. I clearly remembered I used Axis 1.2alpha with jdk1.4.2.
Just recently i updated my jdk to 1.5 and i dont have two machines to prove my point.
Steve Stewart
Greenhorn

Joined: May 13, 2005
Posts: 1
Henry

Balaji is correct. Axis 1.2 works fine with 1.4.2. It also works fine under 1.5 too.

I've been using 1.2 for a few months, well the Release Candidates anyway and it appears to work as intended.
Steve
Henry Wong
author
Sheriff

Joined: Sep 28, 2004
Posts: 18505
    
  40

Thanks... I guess when I have the time, I'll take a look at it again. It is probably something really minor.

Henry
Ashutosh Shahi
Ranch Hand

Joined: Feb 06, 2005
Posts: 36
Henry,
Axis 1.2 very much works with JDK 1.4. Guess your problem is with typemapping. Axis 1.1 puts typemapping as 1.1 by default and in Axis 1.2, the default is 1.2, though the doc still stays 1.1.

Try giving --typeMappingVersion 1.1 to WSDL2Java and see if it helps.

Ashutosh
Henry Wong
author
Sheriff

Joined: Sep 28, 2004
Posts: 18505
    
  40

Originally posted by Ashutosh Shahi:
Henry,
Axis 1.2 very much works with JDK 1.4. Guess your problem is with typemapping. Axis 1.1 puts typemapping as 1.1 by default and in Axis 1.2, the default is 1.2, though the doc still stays 1.1.

Try giving --typeMappingVersion 1.1 to WSDL2Java and see if it helps.

Ashutosh


Thanks... I'll take a look at it, when I revisit the issue.

Henry
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Does Axis 1.2 require Java 5.0?
 
Similar Threads
Switch statement - Constant expression
classpath of JAR files
Problem with Setting up Jakarta Logging with AXIS
help apache axis
SOAP and WSAD V5.0