aspose file tools*
The moose likes Web Services and the fly likes Newbie Question: Axis installation problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "Newbie Question: Axis installation problem" Watch "Newbie Question: Axis installation problem" New topic
Author

Newbie Question: Axis installation problem

Jon Lee
Ranch Hand

Joined: Mar 04, 2005
Posts: 134
Newbie Question: Axis installation problem

I installed Axis following the official instructions on http://ws.apache.org/axis/java/install.html. I have installed JDK 1.5, Tomcat 5.5 and Axis 1.1. I can see the page http://localhost:8080/ which means Tomcat is running well. And I can see the page http://localhost:8080/axis/. I also pass the test on http://localhost:8080/axis/happyaxis.jsp. All needed components are checked ok. Only two optional axis libraries are missing: xmlsec.jar and mail.jar. I even can see the result of http://localhost:8080/axis/services/Version?wsdl and http://localhost:8080/axis/services/AdminService?wsdl. But when I try to test a SOAP endpoint by open the page http://localhost:8080/axis/services/Version?method=getVersion, the return is "The page cannot be displayed, HTTP 500 - Internal server error". Does anyone experience the same error? Any suggestions will help!!! Thnx a lot!!

OS: Win XP;
classpath: .
[ May 28, 2005: Message edited by: Jon Lee ]

SCJP 5.0 - 98% (2007)<br />SCWCD 1.4 - 97% (2007)
Balaji Loganathan
author and deputy
Bartender

Joined: Jul 13, 2001
Posts: 3150
what does the log files for tomcat says?
Where u able to deploy and consume some service?
for example try installing some .jws files and how its goes ?
Jon Lee
Ranch Hand

Joined: Mar 04, 2005
Posts: 134
Problem solved, mate.

Just remove Axis 1.1 and try axis-1_2RC2. Axis 1.1 may not be compatible with TomCat 5.5!!!
 
 
subject: Newbie Question: Axis installation problem