This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes Web Services and the fly likes [Fatal Error] :2:15: The prefix Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "[Fatal Error] :2:15: The prefix "env" for element "env:Envelope" is not bound." Watch "[Fatal Error] :2:15: The prefix "env" for element "env:Envelope" is not bound." New topic
Author

[Fatal Error] :2:15: The prefix "env" for element "env:Envelope" is not bound.

Ellen Zhao
Ranch Hand

Joined: Sep 17, 2002
Posts: 581
Hi folks,

I'm trying to run a SOAP (version 1.2) web service, here are the request.xml and response.xml:


And here are my servlet class and a simple client takes nine blocks of infoSymbol and a URL. The client firstly build a request file in xml like I listed above and then send the xml file to the URL where the service exists. My code list:



The servlet is deloyed at my localhost, in a Tomcat 5.0. There was this error:

[Fatal Error] :2:15: The prefix "env" for element "env:Envelope" is not bound.
org.xml.sax.SAXParseException: The prefix "env" for element "env:Envelope" is not bound.


when the client ran. I'm new to web service and SOAP programming, could anyone please enlighten me about what was wrong? Thank you very much in advance!


Regards,
Ellen
Ellen Zhao
Ranch Hand

Joined: Sep 17, 2002
Posts: 581
ah ha! it's funny, I haven't got the SOAP server up and running..... Working on that....
 
 
subject: [Fatal Error] :2:15: The prefix "env" for element "env:Envelope" is not bound.