This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Web Services and the fly likes java.lang. NoClassDefFoundError when trying to load a class in my war file. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "java.lang. NoClassDefFoundError when trying to load a class in my war file." Watch "java.lang. NoClassDefFoundError when trying to load a class in my war file." New topic
Author

java.lang. NoClassDefFoundError when trying to load a class in my war file.

Tony Evans
Ranch Hand

Joined: Jun 29, 2002
Posts: 573
I have a ear file which contains a war file webservice, in my war file I have a application
AntiVirusProcess which calls another class test.class
inside a jar file config.jar The war file manifest.mf contains

Manifest-Version: 1.0

Name: WEB-INF/classes/ language_builtins/ lang/ArrayOfStringCodec.class

Name: META-INF/MANIFEST.MF

Name: AntiVirus_client.jar

Name: WEB-INF/classes/ language_builtins/lang/holders/ ArrayOfStringHolder.class

Name: WEB-INF/web.xml

Name: WEB-INF/lib/config.jar

Name: WEB-INF/web-services.xml

Name: WEB-INF/lib/middleware_EJB.jar

Name: WEB-INF/classes/uk/gov/ir/ eric/webservices/ antivirus/AntiVirusProcess.class

The config.jar is under WEB-INF/lib/

But I still get this exception when I call test inside my code

javax.xml.rpc. soap.SOAP FaultException:
Exception during processing:
java.lang.NoClass DefFoundError:
uk/gov/ir/eric/ webservices /antivirus/test

Thanks for any help Tony
 
jQuery in Action, 2nd edition
 
subject: java.lang. NoClassDefFoundError when trying to load a class in my war file.
 
Similar Threads
Deploying .war containing JavaFX .jar to JBoss - NoClassDefFoundError
Do we have Application specific class-path?
Problems setting up website with context.xml inside META-INF
Mysterious Spring Configuration Errors
Problem in config. JPA in JBOSS