aspose file tools*
The moose likes Web Services and the fly likes IWAB0398E Error in generating WSDL from Java Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "IWAB0398E Error in generating WSDL from Java " Watch "IWAB0398E Error in generating WSDL from Java " New topic
Author

IWAB0398E Error in generating WSDL from Java

Himanshu Bisht
Ranch Hand

Joined: Aug 27, 2004
Posts: 96
hi
I am try to run a web service from eclipse using a Bottom Up Web Service tutorial.Everything is fine but in the end it gives this error

IWAB0398E Error in generating WSDL from Java java.lang.NoClassDefFoundError: javax/wsdl/extensions/ExtensibilityElement

it took me 3 days to configure my eclipse and now it gives this.Tried googling this error but was not of much help.

If someone can give some hint, it will be a great help.

thanks
Peer Reynders
Bartender

Joined: Aug 19, 2005
Posts: 2922
    
    5
The javax.wsdl.extensions.ExtensibilityElement class resides in the wsdl4j.jar in the axis/lib directory - so that JAR has to be in your classpath. So I guess it isn't in your class path variables of your project's Java Build Path. To ensure that your installation is in order, it might be an idea to verify from the command-line that its works.
Himanshu Bisht
Ranch Hand

Joined: Aug 27, 2004
Posts: 96
well I have it in my class path.
These are my .classpath file entries:

<classpathentry kind="lib" path="C:/Documents and Settings/himanshub/workspace/Converter/WebContent/WEB-INF/lib/commons-discovery.jar"/>
<classpathentry kind="lib" path="C:/Documents and Settings/himanshub/workspace/Converter/WebContent/WEB-INF/lib/commons-logging.jar"/>
<classpathentry kind="lib" path="C:/Documents and Settings/himanshub/workspace/Converter/WebContent/WEB-INF/lib/wsdl4j.jar"/>
<classpathentry kind="lib" path="C:/Documents and Settings/himanshub/workspace/Converter/WebContent/WEB-INF/lib/log4j-1.2.8.jar"/>
<classpathentry kind="lib" path="C:/Documents and Settings/himanshub/workspace/Converter/WebContent/WEB-INF/lib/axis.jar"/>
<classpathentry kind="lib" path="C:/Documents and Settings/himanshub/workspace/Converter/WebContent/WEB-INF/lib/jaxrpc.jar"/>
<classpathentry kind="lib" path="C:/Documents and Settings/himanshub/workspace/Converter/WebContent/WEB-INF/lib/saaj.jar"/>
<classpathentry kind="lib" path="C:/Documents and Settings/himanshub/workspace/Converter/WebContent/WEB-INF/lib/axis-ant.jar"/>

moreover I manually copied these files to my project's lib folder but still it results to the same error.
Peer Reynders
Bartender

Joined: Aug 19, 2005
Posts: 2922
    
    5
I was a bit surprised to see "wsdl4j.jar"
  • Axis 1.2 and 1.3 are distributed with wsdl4j-1.5.1.jar, commons-discovery-0.2.jar, commons-logging-1.0.4.jar
  • You can always check to see if that JAR actually contains javax.wsdl.extensions.ExtensibilityElement (as javax/wsdl/extensions/ExtensibilityElement.class). Copy the JAR to a different location and the change the copy's extension from .jar to .zip and then simply look into it.

  • Sometimes it's just easier to get things working (and figure out what you need in your classpath) from the command-line. Work in a console window. Simply create a .bat that contains something like

    Keep adding to the %AXISCLASSPATH% until Java2WSDL is finally happy. Above you can see the path that I had to create to make WSDL2Java happy.

    However when working with the command-line keep in mind:
  • IIRC maximum length for both the entire command-line and a single environment variable is 2048 bytes for Windows NT, 2000 and 8192 bytes for Windows XP and above (could have been worse).
  • When there are spaces in the path, you have to enclose the file pathname in quotes to stop option parsing from breaking.

  • I'm still paranoid from the olden days where everthing was limited to 256, so your base library path of "C:/Documents and Settings/himanshub/workspace/Converter/WebContent/WEB-INF/lib/" 79 + 2 quotes = 81 characters would make me sweat - my base library path (D:\etc\axis\lib) has only 15 characters and no spaces.
    [ February 18, 2006: Message edited by: Peer Reynders ]
    Himanshu Bisht
    Ranch Hand

    Joined: Aug 27, 2004
    Posts: 96
    this is what I get when eclipse tries to deploy web service to axis run time

    IWAB0489E Error when deploying Web service to Axis runtime
    java.lang.NullPointerException

    i think its a configuration problem of axis.


    I tried the command prompt method but this is what it says.I used both 1.1 and 1.2.



    dont know if I am doing it the right way or not.
    Peer Reynders
    Bartender

    Joined: Aug 19, 2005
    Posts: 2922
        
        5
    Originally posted by Himanshu Bisht:



    Contrary to what the some of the axis documentation says the tool's help seems to be asking for:

    -p samples.userguide.example6=urn:Example6

    rather than

    -p "samples.userguide.example6" "urn:Example6"
    chetan dhumane
    Ranch Hand

    Joined: Jan 07, 2009
    Posts: 629

    I am using eclipse for axis.
    and all jar are available in the lib folder even though i get same error .


    http://www.androcid.com/
     
     
    subject: IWAB0398E Error in generating WSDL from Java