Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

AxisFault Exception... was it a valid wsdd descriptor

 
Sunny Suresh
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am using eclipse3.1, Lomboz3.1 and Jboss4.04RC1. And for webservices i down loaded Apache Axis 1.2.1 and installed.

Everything working fine. Happy axis and all.

Now my problem is that. I have followed the TUSC tutorals. On chapter 9.

I created new deploy.wsdd. and After giving this command in working directory, I got this message.

>> java org.apache.axis.client.AdminClient deploy.wsdd

I got this messages...

Processing file deploy.wsdd
Exception: AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}
Server.userException
faultSubcode:
faultString: java.lang.Exception: Unable to process the message -was it
a valid WSDD descriptor?
faultActor:
faultNode:
faultDetail: {http://xml.apache.org/axis/}hostname:indpro1

i used this wsdd file....

<?xml version="1.0" encoding="UTF-8"?>
<deployment xmlns="http://xml.apache.org/axis/wsdd"
xmlns:java="http://xml.apache.org/axis/wsdd/providers/java" >

<service name="MyStoreLoginService" provider="java:EJB">

<parameter name="beanJndiName" value="StoreAccessLocal"/>
<parameter name="homeInterfaceName" value="au.com.tusc.session.StoreAccessLocalHome"/>
<parameter name="remoteInterfaceName" value="au.com.tusc.session.StoreAccessLocal"/>

<parameter name="allowedMethods" value="loginUser"/>
<parameter name="jndiURL" value="jnp://localhost:1099"/>
<parameter name="jndiContextClass" value="org.jnp.interfaces.NamingContextFactory"/>
</service>
</deployment>

OR

<?xml version="1.0" encoding="UTF-8"?>
<deployment xmlns="http://xml.apache.org/axis/wsdd"
xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">

<service name="MyStoreLoginService" provider="java:EJB">
<parameter name="beanJndiName" value="StoreAccessBean"/>
<parameter name="homeInterfaceName" value="au.com.tusc.session.StoreAccessHome"/>
<parameter name="remoteInterfaceName" value="au.com.tusc.session.StoreAccess"/>
<parameter name="allowedMethods" value="loginUser"/>
<parameter name="jndiURL" value="jnp://localhost:1099"/>
<parameter name="jndiContextClass" value="org.jnp.interfaces.NamingContextFactory"/>
</service>
</deployment>


Please help me. I am getting trouble and struggle with 2 weeks.

Regards,
Sunny Suresh M.
 
Maniganda Prakashh
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey,

I also faced the same problem. I could resolve the problem by changing the following line:
<deployment xmlns="http://xml.apache.org/axis/wsdd"

solution:
<deployment xmlns="http://xml.apache.org/axis/wsdd/"

Look one slash is added at the end of wsdd.

Hope it would be helpful
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic