jQuery in Action, 3rd edition
The moose likes Web Services and the fly likes build not found Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Java Interview Guide this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "build not found" Watch "build not found" New topic

build not found

ahsan mir
Ranch Hand

Joined: Jul 17, 2006
Posts: 42
I am using the Sun J2ee application server and the tutorial for trying out web services.
When i try to 'asant'(compile)a simple web service , i get an error of 'build' not found, even though its ther.
C:\javaeetutorial5\examples\jaxws\helloservice>asant build
Buildfile: build.xml

Target `build' does not exist in this project.

Total time: 0 seconds


Directory of C:\javaeetutorial5\examples\jaxws\helloservice

11/05/2006 11:00 <DIR> .
11/05/2006 11:00 <DIR> ..
11/05/2006 11:00 1,142 build.xml
11/05/2006 11:00 <DIR> nbproject
11/05/2006 11:00 <DIR> src
11/05/2006 10:59 <DIR> web

William Brogden
Author and all-around good cowpoke

Joined: Mar 22, 2000
Posts: 13037
That is the error you get from ANT when build.xml does not have an entry

Perhaps you should be trying to build from another directory where the build.xml does have a "build" target?
ahsan mir
Ranch Hand

Joined: Jul 17, 2006
Posts: 42
could you please elaborate a lil bit. I have done exactly what the turorial says.


My environmental variables are:

I agree. Here's the link: http://aspose.com/file-tools
subject: build not found
It's not a secret anymore!