File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Web Services and the fly likes certificates,https, axis and weblogic 8.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "certificates,https, axis and weblogic 8.1" Watch "certificates,https, axis and weblogic 8.1" New topic
Author

certificates,https, axis and weblogic 8.1

Arthur Ford
Greenhorn

Joined: Sep 06, 2006
Posts: 22
Hi Folks,

I have been trying this for the last couple of weeks. I want to deploy a webserivice in weblogic which shud be accessed by https.

My webservice shud be registered as https://localhost:7002/XContext/XService/XPort

For this I am using apache axis 1.4. I used the demo trust and demo key in weblogic. When I try to run AdminClient I get this error -


Then I did some R&D, and I guess I need to set up my server with some keystores.

I did have a certificatefile PEM and a keyfile PEM. I tried using the utils.ImportPrivateKey. Now, I get this error


Now I am totally confused and I have no clue abt this. Any help will do.
Kanu Dialani
Greenhorn

Joined: Apr 30, 2005
Posts: 23
Hi
I was using SOAP-UI for testing one of our web services. Even i got that same SSL exception. ALl i did was imported the certificate into the default cacerts of the JRE and it worked fine.
 
wood burning stoves
 
subject: certificates,https, axis and weblogic 8.1
 
Similar Threads
SSL Certificate Compatibility Issue in Tomcat 4.1
Axis error
(Q by S)exception faultString: java.net.ConnectException: Connection refused: connect
Authentication web services
SSL, AXIS, Web Service