aspose file tools
The moose likes Web Services and the fly likes Axis Fault while deploying !!!Help me Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Groovy Fundamentals video training course this week in the Groovy forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Axis Fault while deploying !!!Help me" Watch "Axis Fault while deploying !!!Help me" New topic
Author

Axis Fault while deploying !!!Help me

vasu venki
Greenhorn

Joined: Oct 05, 2005
Posts: 19
hi there i am facing the following problem while trying examples from the following site http://www.ammai.com/modules.php?op=modload&name=Sections&file=index&req=printpage&artid=5
pls help me out.

D:\jakarta-tomcat-5.5.9\webapps\axis>java org.apache.axis.client.AdminClient dep
loy.wsdd
Processing file deploy.wsdd
Exception: AxisFault
faultCode: {http://xml.apache.org/axis/}HTTP
faultSubcode:
faultString: (401)Unauthorized
faultActor:
faultNode:
faultDetail:
{}:return code: 401
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML><HEAD>
<TITLE>401 Unauthorized</TITLE>
</HEAD><BODY><H1>Unauthorized</H1>
</BODY></HTML>

{http://xml.apache.org/axis/}HttpErrorCode:401


D:\jakarta-tomcat-5.5.9\webapps\axis>


SCJP:70%<br />SCWCD:86%<br />SCBCD:90%<br />scdjws:98%<br />OCA<br />Nothing is impossible.Try and try until you achieve it.<br /> <br />Interstesigning and developing web Components
Amit K Srivastava
Greenhorn

Joined: May 16, 2006
Posts: 23
Have you tried deploying using different options in AdminCLient.. One could be your Axis servlet must not be accessible on default url.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Axis Fault while deploying !!!Help me