• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem with Namespace Prefix in AXIS

 
Anup Bansal
Ranch Hand
Posts: 69
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am using AXIS 1.4 to access a Webservice. I am able to properly connect to the service and receive the response.
However I am facing a problem in validating the response.
The webservice sends the response with different namespace prefixes and by the time I receive the response, the namespace prefixes are modified and hence the validation fails.
I have set the value of enableNamespacePrefixOptimization to 'true' in my client-config.wsdd but this too does not seem to work.

Can anyone please provide me the solution to this?

Thansk in advance,
Anup
 
Paul Clapham
Sheriff
Pie
Posts: 20171
24
MySQL Database
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If your validation depends on a particular namespace prefix then it is wrong. As long as the namespace prefix is mapped to the correct namespace URI, it doesn't matter what you choose for the prefix. That's a rule of XML and namespaces.

So the solution (unless I misunderstand the question) is to fix the validation to not depend on a specific namespace prefix.
 
Anup Bansal
Ranch Hand
Posts: 69
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Paul!
I understand your concern. But this is how the webservice has been designed.
We cannot change it as that is a third party service and so that is not an option. Can we in anyway make AXIS use the prefixes as received?

Regards,
Anup
 
Don't get me started about those stupid light bulbs.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic