aspose file tools*
The moose likes Web Services and the fly likes AxisFault and NullPointerException when calling a simple web service Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "AxisFault and NullPointerException when calling a simple web service" Watch "AxisFault and NullPointerException when calling a simple web service" New topic
Author

AxisFault and NullPointerException when calling a simple web service

Bob Peterson
Ranch Hand

Joined: Jul 30, 2004
Posts: 47
Initially, I thought my problem was similar to this one :

http://www.coderanch.com/t/223143/Web-Services/java/Null-Pointer-Exception-encountered-when

But I don't think so. We have an existing web service that's been running fine for awhile. I'm trying to create a new service within the same codebase/WAR, just at a different URL. I'm using Axis 1.2, WSAD 5.1, and Java 1.3 (yes, we're that far behind).

We have a WS client class that encapsulates the call to our own services, for testing purposes. I've added a new method to this class which uses a new request XML to call the new service. The 'old' calls to the old service, from within this same client class, work fine. The new call creates the exception below.

So since the old calls from within the same class work fine, I don't think it's the classpath issue mentioned in the thread above.

The new request XML validates and is very simple :





Any ideas? Thanks
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: AxisFault and NullPointerException when calling a simple web service