aspose file tools*
The moose likes Web Services and the fly likes Facing Problem in Web Service Client - Server.NoService Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Facing Problem in Web Service Client - Server.NoService" Watch "Facing Problem in Web Service Client - Server.NoService" New topic
Author

Facing Problem in Web Service Client - Server.NoService

Baskaran Ragav
Greenhorn

Joined: Apr 13, 2007
Posts: 14
Hi,

I am getting this error when i run my web service client

AxisFault
faultCode: {http://xml.apache.org/axis/}Server.NoService
faultSubcode:
faultString: The AXIS engine could not find a target service to invoke! targetService is null
faultActor:
faultNode:
faultDetail:
{http://xml.apache.org/axis/}hostname:01HW128680

The AXIS engine could not find a target service to invoke! targetService is null
at org.apache.axis.message.SOAPFaultBuilder.createFault(SOAPFaultBuilder.java:222)
at org.apache.axis.message.SOAPFaultBuilder.endElement(SOAPFaultBuilder.java:129)
at org.apache.axis.encoding.DeserializationContext.endElement(DeserializationContext.java:1087)
at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndElement(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
at org.apache.xerces.parsers.DTDConfiguration.parse(Unknown Source)
at org.apache.xerces.parsers.DTDConfiguration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at javax.xml.parsers.SAXParser.parse(SAXParser.java:379)
at org.apache.axis.encoding.DeserializationContext.parse(DeserializationContext.java:227)
at org.apache.axis.SOAPPart.getAsSOAPEnvelope(SOAPPart.java:696)
at org.apache.axis.Message.getSOAPEnvelope(Message.java:435)
at org.apache.axis.handlers.soap.MustUnderstandChecker.invoke(MustUnderstandChecker.java:62)
at org.apache.axis.client.AxisClient.invoke(AxisClient.java:206)
at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
at org.apache.axis.client.Call.invoke(Call.java:2767)
at org.apache.axis.client.Call.invoke(Call.java:2443)
at org.apache.axis.client.Call.invoke(Call.java:2366)
at org.apache.axis.client.Call.invoke(Call.java:1812)
at com.samples.ws.intf.SampleWebServiceSoapBindingStub.getName(Unknown Source)
at com.samples.ws.client.WebServiceClient.main(WebServiceClient.java:26)
Exception in thread "main"

Though the web service deployment looks successful.
When i hit the page http://localhost:8080/SimpleWebServiceWAR/services/SampleWebService
i am getting Hi there, this is an AXIS service! message.


This is my client code
-------------------------------------------------------------------
public static void main(String[] a) throws Exception
{
WebServiceIntfService service = new WebServiceIntfServiceLocator();
WebServiceIntf intf = service.getSampleWebService(new URL("http://localhost:8080/SimpleWebServiceWAR/services/SampleWebService"));
String response = intf.getName(10); // web service method
System.out.println(response);
}

Can any one high light me where its going wrong.
Thanks
Ragav
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60077
    
  65

"Raghven k b",

There aren't many rules that you need to worry about here on the Ranch, but one that we take very seriously regards the use of proper names. Please take a look at the JavaRanch Naming Policy and adjust your display name to match it.

In particular, your display name must be a first and a last name separated by a space character, and must not be obviously fictitious.

Thanks!
bear
JavaRanch Sheriff


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Ugender Rekulampally
Ranch Hand

Joined: Nov 14, 2005
Posts: 130
Raghven,

Did you deploy your service using deploy.wsdd script on to the server you are using?

and by the way, which application server are you using?

Thanks,
Ugender
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Facing Problem in Web Service Client - Server.NoService
 
Similar Threads
AXIS Web Service Client unable to call WebSphere 5.0 Deployed EJB
Using web services in Java
faultString: org.xml.sax.SAXParseException: Premature end of file.
AxisFault : java exception
Unable to send mail via Web Service