aspose file tools*
The moose likes Web Services and the fly likes issue with Tomcat 3.2.4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "issue with Tomcat 3.2.4" Watch "issue with Tomcat 3.2.4" New topic
Author

issue with Tomcat 3.2.4

Carolina Martinez
Greenhorn

Joined: Oct 08, 2007
Posts: 2
when using Tomcat now I am getting the next error since using JDK 1.3

Exception in: R( /timesheet + /servlet/payroll.manager + null) - java.lang.NoSuchMethodError: getXMLReader ()Lorg/xml/sax/XMLReader;
java/lang/Throwable.<init>(Ljava/lang/String ;) V+4 (Throwable.java:85)
java/lang/Error.<init>(Ljava/lang/String ;) V+1 (Error.java:41)
java/lang/IncompatibleClassChangeError.<init>(Ljava/lang/String ;) V+1 (IncompatibleClassChangeError.java:34)
java/lang/NoSuchMethodError.<init>(Ljava/lang/String ;) V+1 (NoSuchMethodError.java:37)
com/ibm/as400/data/PcmlSAXParser.<init>(Ljava/lang/String;Ljava/lang/ClassLoader;Ljava/io/InputStream ;) V+472 (PcmlSAXParser.java:222)
com/ibm/as400/data/ProgramCallDocument.loadSourcePcmlDocument(Ljava/lang/String;Ljava/lang/ClassLoader;Ljava/io/InputStream ;) Lcom/ibm/as400/data/PcmlDocument;+2 (ProgramCallDocument.java:1410)
com/ibm/as400/data/ProgramCallDocument.loadPcmlDocument(Ljava/lang/String;Ljava/lang/ClassLoader;Ljava/io/InputStream ;) Lcom/ibm/as400/data/PcmlDocument;+26 (ProgramCallDocument.java:1242)
com/ibm/as400/data/ProgramCallDocument.<init>(Lcom/ibm/as400/access/AS400;Ljava/lang/String ;) V+27 (ProgramCallDocument.java:131)
com/cpui/PayrollBatch.getdetail(Lcom/cpui/user/User;IIILjava/sql/Connection ;) V+4066 (PayrollBatch.java:585)
com/cpui/payroll/manager.doGet(Ljavax/servlet/http/HttpServletRequest;Ljavax/servlet/http/HttpServletResponse ;) V+0 (manager.java:304)
javax/servlet/http/HttpServlet.service(Ljavax/servlet/http/HttpServletRequest;Ljavax/servlet/http/HttpServletResponse ;) V+32 (HttpServlet.java:740)
javax/servlet/http/HttpServlet.service(Ljavax/servlet/ServletRequest;Ljavax/servlet/ServletResponse ;) V+25 (HttpServlet.java:853)
org/apache/tomcat/core/ServletWrapper.doService(Lorg/apache/tomcat/core/Request;Lorg/apache/tomcat/core/Response ;) V+66 (ServletWrapper.java:405)
org/apache/tomcat/core/Handler.service(Lorg/apache/tomcat/core/Request;Lorg/apache/tomcat/core/Response ;) V+198 (Handler.java:287)
org/apache/tomcat/core/ServletWrapper.service(Lorg/apache/tomcat/core/Request;Lorg/apache/tomcat/core/Response ;) V+139 (ServletWrapper.java:372)
org/apache/tomcat/core/ContextManager.internalService(Lorg/apache/tomcat/core/Request;Lorg/apache/tomcat/core/Response ;) V+260 (ContextManager.java:806)
org/apache/tomcat/core/ContextManager.service(Lorg/apache/tomcat/core/Request;Lorg/apache/tomcat/core/Response ;) V+15 (ContextManager.java:752)
org/apache/tomcat/service/connector/JNIConnectionHandler.processConnection(JJ)V+253 (JNIConnectionHandler.java:186)
org/apache/tomcat/service/JNIEndpoint.service(JJ)I+13 (JNIEndpoint.java:176)

Any ideas ?
[ October 08, 2007: Message edited by: Ulf Dittmer ]
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42608
    
  65
Welcome to JavaRanch.

when using Tomcat now I am getting the next error since using JDK 1.3

What do you mean by "since using JDK 1.3"? Did you use a different JDK before and it worked? Which version was that?


Ping & DNS - my free Android networking tools app
Carolina Martinez
Greenhorn

Joined: Oct 08, 2007
Posts: 2
well, my customer was in a different release and he was using JDK 1.2
He said since he moved to v5r4 now he is using JDK 1.3 and he is getting the error.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: issue with Tomcat 3.2.4