*
The moose likes Web Services and the fly likes Web services :Facing problem on setting value of xs:ID Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "Web services :Facing problem on setting value of xs:ID" Watch "Web services :Facing problem on setting value of xs:ID" New topic
Author

Web services :Facing problem on setting value of xs:ID

manishkumarlal cs
Greenhorn

Joined: Oct 25, 2005
Posts: 11
Hi,
I have created a web service, the xsd contains one element thats of type xs:ID. On the client side i am setting the request object, although all the attributes gets the value assigned, but the value corresponding to xs:ID is not set and giving NULL.

Can anyone help me in this regard.

Thanks
Manish
Peer Reynders
Bartender

Joined: Aug 19, 2005
Posts: 2922
    
    5
Originally posted by manishkumarlal cs:
the xsd contains one element thats of type xs:ID.


The XML specification recommends that the ID attribute type should only be used on attributes (for compatibility reasons). Furthermore any value assigned to it must begin with a letter or underscore.

What are you hoping to gain by using a xsd:ID over a simple and straightforward xsd:string?
 
jQuery in Action, 2nd edition
 
subject: Web services :Facing problem on setting value of xs:ID
 
Similar Threads
problem with Getter Method
how to set the value of a boolean in javascript
what does this do?
Thread safety and cookie age question...
Request.getParameter() coming as Null in IE