jQuery in Action, 2nd edition*
The moose likes Web Services and the fly likes Axis 2 - MTOM Service problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Axis 2 - MTOM Service problem" Watch "Axis 2 - MTOM Service problem" New topic
Author

Axis 2 - MTOM Service problem

Manuj Bawa
Greenhorn

Joined: Dec 13, 2004
Posts: 7
Hi,

I have written a webservice which takes in a paramter (file name with path) and returns its binary data within a DataHandler



The WSDL goes as follows:



The webservice works perfectly fine when invoked using a stand alone client, but when invoked from within the web-application that hosts this webservice, it pops up an Axis Fault:

I have tried disabling addressing in axis2.xml completely, tried sending the action explicitly but have not been able to make it work when the WS is invoked from within the web application.

Services.xml



The WebServer is WebSphere 6.1. MTOM is enabled in axis2.xml.

Any Ideas? Help appreciated, my mind has stopped working today to read up about WS-Addressing and analyze this...

Thanks,
Manuj
[ December 27, 2007: Message edited by: Manuj Bawa ]
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Axis 2 - MTOM Service problem
 
Similar Threads
Web Service Deployment problem
axis2/webshpere response != axis2/glassfish response........ why?
adding new operation in web service interface
Objects, web services and netbeans
XmlException on calling WSDL2Java