wood burning stoves*
The moose likes Web Services and the fly likes Axis2 wizard problems in eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "Axis2 wizard problems in eclipse" Watch "Axis2 wizard problems in eclipse" New topic
Author

Axis2 wizard problems in eclipse

Doug Slattery
Ranch Hand

Joined: Sep 15, 2007
Posts: 294
I'm having problems using the web service client wizard. Sometimes it works, but when it doesn't, it is a problem on the final dialog.

On the first dialog, I copy/paste the wsdl url for the service definition from a browser window. Client type: Java Proxy (default)
Configuration:
Server: Tomcat v5.5 Server
Web service runtime: Apache Axis2
Client project: <my eclipse dynamic web project>
Monitor the Web service: unchecked (default)
Overwrite files without warning: checked (default)

When I click Next to go to the Axis2 Client Web Service Configuration dialog, when it works, the combo boxes are filled in. ATM, they're all blank except the Databinding Name, which defaults to ADB. Once, I was able to get it to work by trying different values for the Web service runtime selection on the previous dialog. It's not working this time though.

Any ideas?

Aloha,
Doug

-- Nothing is impossible if I'mPossible
Doug Slattery
Ranch Hand

Joined: Sep 15, 2007
Posts: 294
Problem solved...

There was an entry set that I made on the wizard that didn't match the corresponding wsdl setting.

Aloha,
Doug

-- Nothing is impossible if I'mPossible
Jason Binder
Greenhorn

Joined: Jul 28, 2010
Posts: 1
Hi, I am having the same issue and I'm wondering if you could elaborate on the solution you found?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Axis2 wizard problems in eclipse