Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

doubt in webservices

 
kanthi kiran
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi friends,

i have written a web service client and started executing it... but i am getting an exception.

Exception in thread "main" javax.xml.rpc.ServiceException: Failed to create factory: org.apache.axis.client.ServiceFactory
at javax.xml.rpc.ServiceFactory.newInstance(ServiceFactory.java:79)
at webservice1.Client.main(Client.java:13)
Caused by: java.lang.ClassNotFoundException: org.apache.axis.client.ServiceFactory
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at javax.xml.rpc.ServiceFactory.newInstance(ServiceFactory.java:73)
... 1 more

actually i am executing this sample example in Eclipse europa with JBoss server....
iam not able to understand this exception. can anyone help me...........

thanks & regards,
Kanthi Kiran
 
pradeep jaladi
Ranch Hand
Posts: 65
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I guess you missed one of the jar files in the class path. Check whether all the jar files which are in classpath
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic