wood burning stoves 2.0*
The moose likes Web Services and the fly likes XFire with Websphere 5.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "XFire with Websphere 5.1" Watch "XFire with Websphere 5.1" New topic
Author

XFire with Websphere 5.1

Padmanabh Sahasrabudhe
Ranch Hand

Joined: Mar 04, 2008
Posts: 53
Hi,

I am trying to deploy a Web Service on Websphere 5.1. I am using XFire to generate the binding classes and having some issues.
[4/15/08 2:47:39:102 EDT] 3f38bcce WebGroup E SRVE0020E: [Servlet Error]-[XFireServlet]: Failed to load servlet: java.lang.ClassCastException: org.codehaus.xfire.transport.http.XFireConfigurableServlet
at com.ibm.ws.webcontainer.webapp.WebAppServletManager.loadServlet(WebAppServletManager.java:188)
at com.ibm.ws.webcontainer.webapp.WebAppServletManager.loadAutoLoadServlets(WebAppServletManager.java:542)
at com.ibm.ws.webcontainer.webapp.WebApp.loadServletManager(WebApp.java:1379)

From the web search I understand that this is somewhere related to the jar conflicts between XFire and Websphere. Has anybody deployed XFire 1.2 on Wepsphere 5.1 successfully?

Thanks
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: XFire with Websphere 5.1
 
Similar Threads
Tuning Thread pool size
Websphere Deployment Issue (Hibernate and Oracle)
Windows Communication Foundation(WCF) WebService and Java client
WSAD 5.1: Failed to load servlet, NoClassDefFoundError
App server cannot find servlet