This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes Web Services and the fly likes Axis 1.4 NoClassDefFoundError on JBoss Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Axis 1.4 NoClassDefFoundError on JBoss" Watch "Axis 1.4 NoClassDefFoundError on JBoss" New topic
Author

Axis 1.4 NoClassDefFoundError on JBoss

Nadeem Awad
Ranch Hand

Joined: Jan 09, 2005
Posts: 74
Hi all,
We have an application deployed on JBoss 4.0.4. Some parts of the application depend on accessing some web services. We are using Apache Axis 1.4 for that.
We had a need to deploy another version of a running application on the same server. After doing so, I noticed that the EJB classes are loaded in a shared class loader, which caused the web application to call the wrong EJBs. Consequently, we�ve changed the JBoss configuration to isolate EAR deployments as follows:

Then the two applications were successfully deployed on the same server. However, since then we�ve started receiving some unexpected exceptions from the server, when the application is trying to access any of the web services using the Axis client. The problem is that the exception message is not descriptive at all, and there�s no specific scenario to trigger them. When we first start up the JBoss, everything works fine. After a certain period of time, this exception happens and we have to restart the JBoss again to resolve it.
The exception stack trace is as follows:



Any help about this urgent issue will be highly appreciated


Share Knowledge to gain it.<br /> <br />SCJP 1.2, SCDJWS 1.4, SCWCD 1.4, SCBCD 1.3, ICAD
Nadeem Awad
Ranch Hand

Joined: Jan 09, 2005
Posts: 74
Any help guys?
 
wood burning stoves
 
subject: Axis 1.4 NoClassDefFoundError on JBoss