This week's book giveaway is in the Cloud/Virtualizaton forum.
We're giving away four copies of Mesos in Action and have Roger Ignazio on-line!
See this thread for details.
Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Axis2: passing an ArrayList to a webservice

 
Pramod Chris
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I don't know if this has been discussed already. I am new to web services and axis2 in particular. I have a web service with a method that takes an ArrayList as a parameter. the ArrayList further has a Hashtable as one of its elements.
when i call the web service from a client, passing the ArrayList as the input, on the server side (at the web service), i am getting <empty>false</empty>. is this a problem of serializing and deserializing paramters? the client code snippet is below..


and my services.xml look like this...


when i print out the arraylist in the webservice it prints <empty>false</empty>
any idea what the issue is?

thanks in advance!
 
Razi Abbas
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Pramod,
While I am no guru on webservices interfaces ... I feel s=you should be able to resolve the problem, if you modify the interface to use Arrays instead of ArrayList. To my feeling (not sure) .. xml has support for Arrays and not for ArrayList ... so the change might be an easy way to solve the issue ...

cheers ...

Razi
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic