Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Axis2: getInboundFaultFrom MessageContext Error!

 
Julio Francisco Vicente S�nchez
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have developped a webservice using Axis2. The webservice uses mtom in order to send large files.

When I call the webservice from a client in a weblogic server, it works ok and I get the file without any problem.

But when I call it from a client in a jboss server I am getting the following error:

org.apache.axis2.AxisFault: java.lang.NullPointerException
at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:486)
at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:343)
at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:389)
at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:211)
at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
at hcdSns.notificaciones.envio.WSProxyAttachementsStub.recepcion(WSProxyAttachementsStub.java:151)
at hcdSns.notificaciones.envio.ClienteEnvioNotificacion.enviarMsgXL(ClienteEnvioNotificacion.java:80)
at hcdSns.ciudadano.model.VerInformeHelper.envioHC007RecepcionHC008(VerInformeHelper.java:99)
at hcdSns.ciudadano.action.VerInformeAction.doAction(VerInformeAction.java:40)

Any idea?

Thanks!call
 
Julio Francisco Vicente S�nchez
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I finally solved it... But I still doesn't know what was the problem...

I was using the 4.0.2 JBoss version... I have updgraded it to 4.2.2 version and now mtom is working correctly.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic