This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes Java Micro Edition and the fly likes ERROR while Running via OTA Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Mobile » Java Micro Edition
Bookmark "ERROR while Running via OTA" Watch "ERROR while Running via OTA" New topic
Author

ERROR while Running via OTA

Harish Tiruvile
Ranch Hand

Joined: Dec 01, 2005
Posts: 99
Hi,

i have created one application using Wireless Tool Kit provided by Sun microsystems.
While running my application Via OTA i got this error

"OTA Error Code (20) - The JAR was not found at the URL given in the JAD. [null]
"


Since WTK is not providing jar file i have created jar file by entering following command
jar cfm MyApp.jar MANIFEST.MF -C D:\j2me\midlet classes

Inside JAR file i am having MANIFEST.MF and CLASSES files\folder

After creating jar file i copied that JAR file into WTK\apps\MyAPP\bin folder.
After copying i executed "Run via OTA" feature of WTK to install application .....it is not getting installed it is giving error.I have searched in google but i have not succeded in finding where i made mistake ..If you know where i made mistake then please write to me..

Thanks in advance for your suggestions


Giving up is the easiest thing in the world to do..but holding it together when everything seems like falling apart is true strength!!
with regards, Harish.T
Pradeep Gudipati
Greenhorn

Joined: Mar 09, 2006
Posts: 16
quote:
--------------------------------------------------------------------
Hi,
i have created one application using Wireless Tool Kit provided by Sun microsystems.
While running my application Via OTA i got this error
"OTA Error Code (20) - The JAR was not found at the URL given in the JAD. [null]"
Since WTK is not providing jar file i have created jar file by entering following command
jar cfm MyApp.jar MANIFEST.MF -C D:\j2me\midlet classes
Inside JAR file i am having MANIFEST.MF and CLASSES files\folder
After creating jar file i copied that JAR file into WTK\apps\MyAPP\bin folder.
After copying i executed "Run via OTA" feature of WTK to install application .....it is not getting installed it is giving error.I have searched in google but i have not succeded in finding where i made mistake ..If you know where i made mistake then please write to me..

Thanks in advance for your suggestions
--------------------------------------------------------------------------
reply:

U need to create a package from the WTK, use the ktoolbar to do this (Project-->Package-->Create Package) the jad and jar files will be created in the bin file and with the right jad attributes.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: ERROR while Running via OTA