aspose file tools*
The moose likes Java Micro Edition and the fly likes Is it A Thread Issue??? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Mobile » Java Micro Edition
Bookmark "Is it A Thread Issue???" Watch "Is it A Thread Issue???" New topic
Author

Is it A Thread Issue???

Naresh Shaan
Greenhorn

Joined: Mar 18, 2006
Posts: 22
Hello All,

i have developed a midlet that talks to a server. i know that every request send to the server must begin in a new thread. and i am doing the same. i ran the midlet on wtk2.2 emulators... the threads are working fine... i was able to send multiple request to the server.

now that i installed the midlet onto my nokia5200 device. when i try to communicate to my server for the very first time, it works fine. but when i send any request after my first, my server receives nothing. my application is not hanging. am able to browse through all my screens. but am nt able to send my second request.

my server is a computer and the communication between my device and my computer is through bluetooth.

for the first time, it clearly asks do you want to connect

but after that it doesnt show any such message and my server gets no message from my mobile phone.

so can any one tell me what can be issue over here

Thanks in Advance!!!


"The greatest pleasure in life is doing what people say you cannot do." - Walter Bagehot
Eduardo Marques
Ranch Hand

Joined: Feb 19, 2005
Posts: 231
Hard to say, seems like a Bluetooth related issue or maybe a problem at the server computer side ...

I've posted a link here on Javaranch related to Bluetooth access source code.

See it at

http://www.coderanch.com/t/230333/JME/Mobile/Sample-code-Bluetooth-ME-access

Maybe it helps somehow ...


Eduardo Marques
Get ready for your SCMAD certification at J2MECertificate.com - See what all the buzz is about ...
Isuru Sampath
Ranch Hand

Joined: Jun 26, 2003
Posts: 57
Try pairing the two devices first if you can this will resolve any auth challenge issues if there are any.

Invoke your phone's Application Manager. It will show you a list of installed applications. Select your program from the list. Go to options. There will be a item called "Network Access", select 'Ask first time' from it.

Now try your program.

Hope this helps. Good luck.


No Winds No Waves
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Is it A Thread Issue???