Meaningless Drivel is fun!*
The moose likes Applets and the fly likes complete newbie with applets here Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Applets
Bookmark "complete newbie with applets here" Watch "complete newbie with applets here" New topic
Author

complete newbie with applets here

tyler jones
Ranch Hand

Joined: Dec 01, 2000
Posts: 101
Okay, I've created an applet exactly as my book tells me to and I've used the applet tags and param tags in my html. Netscape shows my applet fine, but in IE (win2k) I'm just getting a grey box. Can anyone tell me why the newest version of IE doesn't seem to run my applet and netscape will? Is it anything to do with the code? Here's my html code just in case it does.
<applet code="newpalindrome.class" width=600 height=100>
<param name=palindrome value="No, sir, prefer prison">
Your browser does not support Java!
</applet>
One side note...see how I have the part that says "Your browser does not support Java"? Well, this isn't showing up in IE even though it's not running the applet. Just a grey box. Thanks for your help!!!
peter waterhouse
Greenhorn

Joined: Oct 20, 2000
Posts: 15
What does it say on the status bar when you hover the mouse over the grey box?
tyler jones
Ranch Hand

Joined: Dec 01, 2000
Posts: 101
It says load: newpalindrome can't be istantiated. What's weird is since I posted my message, I've got two other applets to come up fine in IE. But again, this first applet (newpalindrome) worked fine in Netscape, so I don't know what to make of it.
Patrick Lentz
Greenhorn

Joined: Oct 04, 2000
Posts: 23
You will need the HTML converter to run applets that use Java2 in IE because this browser doesn't use a JVM that can handle Java2. I think the converter can be find on sun.com/plugins.
Good luck
Patrick
tyler jones
Ranch Hand

Joined: Dec 01, 2000
Posts: 101
If I understand you correctly, you're saying that this applet is a version 2 applet? That stinks cause this book said that as far as teaching applets, it would try to stick with the version that all browsers can work with. I hope that's the reason Thanks.
Daniel Searson
Ranch Hand

Joined: Dec 03, 2000
Posts: 83
Here's a tip: to find out the class/method that causing the problem, click View->Java Console in IE and have a look. If there is no Java Console option, set it through Tools->Internet Options->Advanced.
The console shows where the error (or exception) was generated and you may be able to modify your code to work on older JVM's.
Hope that helps.
------------------
- Daniel


- Daniel
 
Don't get me started about those stupid light bulbs.
 
subject: complete newbie with applets here
 
Similar Threads
applet won't update with latest version
Uable to view swing applet on Sun site!
Query on invoking an Applet on a Linux box.
Installing IE7 broke my applet
problem using browser with applet ??