aspose file tools*
The moose likes Applets and the fly likes Conflict between applets and JVM Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Applets
Bookmark "Conflict between applets and JVM" Watch "Conflict between applets and JVM" New topic
Author

Conflict between applets and JVM

Donnie Brasco
Greenhorn

Joined: Sep 20, 2002
Posts: 4
hi there,
Recently I installed the JSDK 1.4 runtime environment on my system. Since that time I couldn't load any applets anymore in my Internet Explorer browser 6.0. Does anyone know a way to get around this or how to disable/enable the JVM for a while
Thnx
[ September 22, 2002: Message edited by: Donnie Brasco ]
Marilyn de Queiroz
Sheriff

Joined: Jul 22, 2000
Posts: 9053
    
  12
Which OS are you using?


JavaBeginnersFaq
"Yesterday is history, tomorrow is a mystery, and today is a gift; that's why they call it the present." Eleanor Roosevelt
david eberhardt
Ranch Hand

Joined: Jul 02, 2002
Posts: 158
I was having a similar problem ....
I could not display in Netscape 4.7 (which I test in to ensure backward compatibility)
I could not dispplay in IE 6.0 either.
I was using standard <applet></applet> tags
I removed the jdk1.4 that I had installed and recompiled using 1.3
now my simple applets are displaying fine.
Another thread (back in June) in here had been exploring the issues ...http://www.coderanch.com/t/254541/Applets/java/Game-Tutorials-Exploring-Browser-Support
looks like lots of fancy tags and scripts to detect browser type will be req'd going forward ???

terrible problem!
Donnie Brasco
Greenhorn

Joined: Sep 20, 2002
Posts: 4
My OS is Microsoft XP. I unchecked the option Microsoft VM java console enabled in my advanced internet options. Now the applets are working fine.
Marilyn de Queiroz
Sheriff

Joined: Jul 22, 2000
Posts: 9053
    
  12
Originally posted by david eberhardt:

I could not display in Netscape 4.7 (which I test in to ensure backward compatibility)

I could not display in IE 6.0 either.

I was using standard <applet></applet> tags

I removed the jdk1.4 that I had installed and recompiled using 1.3

now my simple applets are displaying fine.


I have no problem displaying simple applets in Netscape 4.7 or Internet Explorer 5.5 with jdk1.4 installed in Win2K.

You might check out Donnie's solution.
Ionel Bute
Greenhorn

Joined: Oct 02, 2002
Posts: 1
Uncheck the JVM in Internet Explorer / Tools/ Advanced and download and install the last JVM(jdk 1.4.1 b21) from Sun and in the Java Plug -in Control Panel /Browser check the boxes for IE or/and Netscape....
Andrew Babaian
Greenhorn

Joined: May 16, 2002
Posts: 25
I am also having a problem viewing applets. I have JDK 1.4.1_01, the plug-in installed, the old microsoft Jave unchecked in the advance tab in IE, W98 and IE 6.0. My Applet viewer shows the applet working. Why can I not get this simple appplet to work?
thanks in advance,
Andrew
import java.applet.*;
import java.awt.*;
public class HelloWorld extends Applet {
public void paint(Graphics g) {
g.drawString("Hello world!", 50, 25);
}
}

<HEAD>
<TITLE> A Simple Program </TITLE>
</HEAD>
<BODY>
Here is the output of my program:
<APPLET CODE = HelloWorld.class WIDTH=200 HEIGHT=50>
</APPLET>
</BODY>
</HTML>
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Conflict between applets and JVM