*
The moose likes Applets and the fly likes Applets not starting at all!!!  Please help!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Applets
Bookmark "Applets not starting at all!!!  Please help!!" Watch "Applets not starting at all!!!  Please help!!" New topic
Author

Applets not starting at all!!! Please help!!

Jean Paul Martin
Ranch Hand

Joined: Oct 05, 2003
Posts: 30
Hi Guys, I have a weird problem .. i have two sorting applets running on a page but nothing is being displayed at all ... they were before but i changed some stuff and now nothing starts .. please help me coz i know these are really simple codes but its been pretty frustrating and i cannot get it back to work ... all i see on the webpage are the windows for the applets but nothing gets painted!! ... THANKS A LOT!!!







[ October 29, 2003: Message edited by: Jean Paul Martin ]
Tony L
Greenhorn

Joined: Jul 31, 2002
Posts: 1
Hi:
You can check the browser whether it support Java applet or not. If not, you can download J2SE JRE to client, and then install it. It may solve your problem.
Ernest Friedman-Hill
author and iconoclast
Marshal

Joined: Jul 08, 2003
Posts: 24183
    
  34


It looks to me as if you intend the paint() method of each applet to call the draw() methods of the sorter objects -- but they don't, they just make a (potentially invalid, in the Microsoft JVM, anyway) cast, and then return. SO the repaint() calls from sort() have no effect.


[Jess in Action][AskingGoodQuestions]
Jean Paul Martin
Ranch Hand

Joined: Oct 05, 2003
Posts: 30
So should just remove the line: if(sorter == null) return; ???
Thanks a lot for your help!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Applets not starting at all!!! Please help!!
 
Similar Threads
Extending another class help!
Adding one more thread
Adding a sound file to a java applet
Thread help!!
First time with applets