"Listener methond names used to "register" a listener with an event source must use the prefix , followed by the listener type."
In the self test, question 5, one of the choices for a method name following the JavaBeans standard is . The answer key says this does not follow the standard. I still don't see why. Granted "size" is an absolutely terrible name for a listener, but if you did name your listener that, wouldn't it still work? Or does "standard" in "JavaBeans standard" imply that you will choose sensible names for your variables?
So, in our errata, we've mentioned that we're going to enhance page 9 to say that by convention Listeners have to end with the word "Listener". We're hoping that that covers it...what do you guys think?
Spot false dilemmas now, ask me how!
(If you're not on the edge, you're taking up too much room.)
I’ve looked at a lot of different solutions, and in my humble opinion Aspose is the way to go. Here’s the link: http://aspose.com