Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Applet only works with one Java version

 
Rob Spoor
Sheriff
Pie
Posts: 20380
46
Chrome Eclipse IDE Java Windows
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've written an applet inside a signed JAR (needs a lot of OS interaction) which works perfectly in Java 1.4.2, which it's also written in.

However, when I try it with different Java versions (1.4.1 and 1.5 are tested) I get the following error:The class is com.hecc.ivr.viewer.ViewerApplet.
I haven't used any special Manifest to create the JAR, which is signed using a local keytool.

The HTML code:This installs Java 1.4.1_03 (most users have that one) if no newer version is installed - if I replace it with 1.4.2_06 (the version used to compile) it still does not work.

Anyone know how I can solve this without requiring Java 1.4.2?
 
Ernest Friedman-Hill
author and iconoclast
Marshal
Pie
Posts: 24204
34
Chrome Eclipse IDE Mac OS X
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HTTP response code 401 is "Unauthorized". Are you sure this is a Java version thing, and not a security thing? Is the web server where the applet lives allowed to send to JAR file to the client machine you're testing on?
 
Rob Spoor
Sheriff
Pie
Posts: 20380
46
Chrome Eclipse IDE Java Windows
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You know, that is a good question.
The web directory it is in now has IIS security on it, so that might be the problem. If so, question is why 1.4.2 does work.

I'll test this tomorrow on my test server (IIS but no security).
 
Rob Spoor
Sheriff
Pie
Posts: 20380
46
Chrome Eclipse IDE Java Windows
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok, security is the problem, and only in Java 1.4.1 - even a machine with only 1.5 worked (although I had to login twice).

Guess I'll have to change the HTML page to require 1.4.2_06 as the minimum.
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic