Meaningless Drivel is fun!*
The moose likes Applets and the fly likes Unable to load Applet in Tomcat 5.5.12 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Applets
Bookmark "Unable to load Applet in Tomcat 5.5.12" Watch "Unable to load Applet in Tomcat 5.5.12" New topic
Author

Unable to load Applet in Tomcat 5.5.12

Amirr Rafique
Ranch Hand

Joined: Nov 14, 2005
Posts: 324
Hi

I am aunable to applet in jsp using Tomcat 5.5.12 and JRE 1.5. Below is the code that I am using
<applet
codebase = "."
archive = "WebPOSApplet.jar"
code = "webposprint.WPMainApplet.class"
name = "Trans Applet"
width = "450"
height = "115"
hspace = "0"
vspace = "0"
align = "middle"
>
<param name = "redirectInfo" value = "SearchProducts.do">
</applet>

<%/*%>
<OBJECT
classid = "clsid:CAFEEFAC-0014-0002-0000-ABCDEFFEDCBA"
codebase = "http://java.sun.com/products/plugin/autodl/jinstall-1_4_2-windows-i586.cab#Version=1,4,2,0"
WIDTH = 450 HEIGHT = 115 >
<PARAM NAME = CODE VALUE = webposprint.WPMainApplet.class>
<PARAM NAME = archive VALUE = WebPOSApplet.jar>
<PARAM NAME = "type" VALUE = "application/x-java-applet;jpi-version=1.4.2">
<param name = "redirectInfo" value = "SearchProducts.do">
<PARAM NAME = "scriptable" VALUE = "false">
<PARAM NAME = model VALUE=models/buckminsterfullerine.xyz>
<embed width="450" height="115" code="webposprint.WPMainApplet.class" archive="WebPOSApplet.jar" type="application/x-java-applet;jpi-version=1.4.2" redirectinfo="SearchProducts.do" scriptable="false" model="models/buckminsterfullerine.xyz" src="webposprint.WPMainApplet.class">
</embed> <COMMENT> <EMBED
type = "application/x-java-applet;jpi-version=1.4.2" \
CODE = webposprint.WPMainApplet.class\
archive = WebPOSApplet.jar\
WIDTH = 373 \
HEIGHT = 167 \
model =models/buckminsterfullerine.xyz \
scriptable = false \
pluginspage = "http://java.sun.com/products/plugin/index.html#download"> <NOEMBED>
alt="Your browser understands the <APPLET>
tag but isn't running the applet, for some reason."
Your browser is completely ignoring the <APPLET>
tag! </NOEMBED> </EMBED> </COMMENT>
</OBJECT>
<%*/%>

This code doesn't seems working with Tomcat 5.5.12. I works fine with Tomcat 4.1.31

Please help
Thanks


"Know where to find the solution and how to use it - that's the secret of success."
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41885
    
  63
What output does it generate?


Ping & DNS - my free Android networking tools app
Amirr Rafique
Ranch Hand

Joined: Nov 14, 2005
Posts: 324
It gives following exception
org.apache.jasper.JasperException: /transactionresult.jsp(304,0) The end tag "</html:html" is unbalanced
org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:39)
org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:405)
org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:130)
org.apache.jasper.compiler.Parser.checkUnbalancedEndTag(Parser.java:1719)
org.apache.jasper.compiler.Parser.parseElements(Parser.java:1574)
org.apache.jasper.compiler.Parser.parse(Parser.java:126)
org.apache.jasper.compiler.ParserController.doParse(ParserController.java:211)
org.apache.jasper.compiler.ParserController.parse(ParserController.java:100)
org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:146)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:286)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:267)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:255)
org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:563)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:293)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1069)
org.apache.struts.action.RequestProcessor.processForwardConfig(RequestProcessor.java:455)
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:279)
org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)
org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:525)
javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

Where as i do have closing tag of HTML
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41885
    
  63
Try to properly close all your elements, e.g.
<PARAM NAME = "scriptable" VALUE = "false" />
instead of
<PARAM NAME = "scriptable" VALUE = "false">

Also try removing the "<APPLET>" part of the ALT tag; it may be throwing off the parser.
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61230
    
  66

Moved to the Applets foru.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Amirr Rafique
Ranch Hand

Joined: Nov 14, 2005
Posts: 324
Hi dudes

The problem got resolved. The starting <html:html> was missing in page.

Thanks for your support and help
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Unable to load Applet in Tomcat 5.5.12