aspose file tools*
The moose likes Applets and the fly likes Applet works from server but not on local machine Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » Applets
Bookmark "Applet works from server but not on local machine" Watch "Applet works from server but not on local machine" New topic
Author

Applet works from server but not on local machine

Flo Powers
Ranch Hand

Joined: May 12, 2004
Posts: 57
Hi, I've been working on a few applets on my machine. They compile fine, and I can load them in the Appletviewer. However, when I tried to open them in IE (or Firefox, for that matter), one of them would freeze up, while the others would run. After a while, none of them would load. I suspect a Java thread was still running (I checked the task manager, and had to terminate the process a few times - could also be working hard running Nortan virus scan and Eclipse at once, with 512MB RAM?).

Anyway, they worked fine in the Appletviewer, and when I tried uploading to my website, it was no problem opening them - they ran like a dream.

Any ideas? It's not a huge hassle - it seems I can trust what I see in the Appletviewer, and the plan is to upload them eventually, so it doesn't really matter so much if I can't view them locally. It's just annoying, and I'm wondering what could be wrong.

Here's what the console has to say:

Java Plug-in 1.5.0_06
Using JRE version 1.5.0_06 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\My name


----------------------------------------------------
c: clear console window
f: finalize objects on finalization queue
g: garbage collect
h: display this help message
l: dump classloader list
m: print memory usage
o: trigger logging
p: reload proxy configuration
q: hide console
r: reload policy configuration
s: dump system and deployment properties
t: dump thread list
v: dump thread stack
x: clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------

Exception in thread "Thread-2" java.lang.IllegalArgumentException
at sun.net.www.ParseUtil.decode(Unknown Source)
at sun.net.www.protocol.file.Handler.openConnection(Unknown Source)
at sun.net.www.protocol.file.Handler.openConnection(Unknown Source)
at java.net.URL.openConnection(Unknown Source)
at sun.applet.AppletPanel.getAccessControlContext(Unknown Source)
at sun.applet.AppletPanel.getClassLoader(Unknown Source)
at sun.applet.AppletPanel.createAppletThread(Unknown Source)
at sun.applet.AppletPanel.init(Unknown Source)
at sun.plugin.AppletViewer.createClassLoader(Unknown Source)
at sun.plugin.AppletViewer.appletInit(Unknown Source)
at sun.plugin.viewer.LifeCycleManager.initAppletPanel(Unknown Source)
at sun.plugin.viewer.IExplorerPluginObject$Initer.run(Unknown Source)
[ March 10, 2006: Message edited by: Flo Powers ]
Chetan Parekh
Ranch Hand

Joined: Sep 16, 2004
Posts: 3636
What your Applets are doing? Post your code.


My blood is tested +ve for Java.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Applet works from server but not on local machine