aspose file tools*
The moose likes Applets and the fly likes Netscape security model - Applet Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Applets
Bookmark "Netscape security model - Applet" Watch "Netscape security model - Applet" New topic
Author

Netscape security model - Applet

Sundar Ram
Ranch Hand

Joined: May 22, 2006
Posts: 102
Hi,

I got an application which uses Netscape security model and I could not find the home page of the Netscape security model to get the supporting library.

Now the applet fails because it does not have any library files related to Netscape security model. So any pointers for getting the applet running is appreciated.

Thanks.

~ Sundar ~


SCJP 5.0 | SCWCD 1.4
http://heysundar.blogspot.com
Sundar Ram
Ranch Hand

Joined: May 22, 2006
Posts: 102
Originally posted by Sundar Ram:
Hi,

I got an application which uses Netscape security model....



Sorry its an applet. And i get the following error message if i try to run it:

"Netscape security model is no longer supported. Please migrate to the Java 2 security model instead."
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42936
    
  68
If you don't have the source code and can change the security model to something newer you're probably out of luck. As that message suggests, those Netscape-specific classes aren't supported any more.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Netscape security model - Applet