Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

scjp 1.4

 
mic ram
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

I am preparing for scjp1.4 exam but i have scjp5 book of kathy serria can i prepare that book and scjp1.4 exam ,can any one suggest whether i can do that way..
 
marc weber
Sheriff
Posts: 11343
Java Mac Safari
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's difficult to prepare for an exam using a book that covers a different version. This is especially true regarding Java 1.4 and 5.0, because these exams are significantly different.

If you have the book for 5.0, I really think you should consider the 5.0 exam. There is a lot of new material on the 5.0 exam that you will be seeing in the book (and will use in practice), so you may as well get certification credit for knowing it. Also, there is some material on the 1.4 exam that is not covered in the 5.0 exam (for example, bit manipulation and the Math class), so if you're taking the 1.4 exam you will need to cover those topics elsewhere.

For a high-level idea of what's different, see SCJP FAQ: How is the 1.5 exam different than the 1.4 exam?
 
Michael Raymond Jr.
Ranch Hand
Posts: 178
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by mic ram:
Hi

I am preparing for scjp1.4 exam but i have scjp5 book of kathy serria can i prepare that book and scjp1.4 exam ,can any one suggest whether i can do that way..


go for whichever one you feel more comfortable with. seeing you have the 5.0 book, it seems to make sense to target that one.

as for learinng the different material between 1.4 and 1.5, well, you don't have to have a certificate on those 'new' 1.5 topics to learn them.

 
Jesper de Jong
Java Cowboy
Saloon Keeper
Posts: 15214
36
Android IntelliJ IDE Java Scala Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Don't use the 5.0 book to study for the 1.4 exam.

The answer of the same exam question can be different, depending on if you're using 1.4 or 5.0. For example, some things do not compile on Java 1.4 but do on Java 5.0. On the exam, the answer "does not compile" would in that case be correct for 1.4, but wrong for 5.0.
 
kurt hanni
Ranch Hand
Posts: 140
Eclipse IDE Java Mac
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
scjp 1.4 read khalid mughal
scjp 5 read k&b
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic