aspose file tools*
The moose likes JSP and the fly likes Deploy jsp with weblogic5.1 error? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "Deploy jsp with weblogic5.1 error?" Watch "Deploy jsp with weblogic5.1 error?" New topic
Author

Deploy jsp with weblogic5.1 error?

Tom Barns
Ranch Hand

Joined: Oct 27, 2000
Posts: 138
Hi All
I have a very simple jsp in the default location which is :
$/weblogic/myserver/public_html/test.jsp
when i use the following url and execute it http://localhost:7001/test.jsp i found 'file download window'
asking where do i need to save my file,it is starnge behavior.
Also i have these setting for jsp properties in weblogic.properties:
# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
# WEBLOGIC JSP PROPERTIES
# ------------------------------------------------
# Sets up automatic page compilation for JSP. Adjust init args for
# directory locations and uncomment to use.
weblogic.httpd.register.DMS.jsp=\
# weblogic.servlet.JSPServlet
c:\inetpub\wwwroot
weblogic.httpd.initArgs.*.jsp=\
pageCheckSeconds=1,\
compileCommand=d:/jdk1.2.2/bin/javac.exe,\
workingDir=d:/weblogic/myserver/classfiles,\
verbose=true

Thanks for your help.
alex almero
Greenhorn

Joined: Jul 19, 2001
Posts: 6
try this configuration...
weblogic.httpd.register.*.jsp=weblogic.servlet.JSPServlet
weblogic.httpd.initArgs.*.jsp=\
pageCheckSeconds=1,\
compileCommand=c:/java/j2sdk/bin/javac.exe,\
workingDir=c:/weblogic/myserver/classfiles,\
verbose=true

best regards
Tom Barns
Ranch Hand

Joined: Oct 27, 2000
Posts: 138
Thanks all.
It is working fine.
Happy Thanksgiving for all.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Deploy jsp with weblogic5.1 error?