Meaningless Drivel is fun!*
The moose likes JSP and the fly likes Taglib's not running Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "Taglib Watch "Taglib New topic
Author

Taglib's not running

Kapil Keskar
Ranch Hand

Joined: Dec 04, 2001
Posts: 47
hello,
I have just prepared a custom tag for establishing database connection. It works fine on my computer having tomcat4.0 server. but don't work on webserver (tomcat). I was unable to locate the problem.
Is it due to server older version? or anything else? what i should do for that?
do i place the server.xml file as per messeage?
checkout the taglib link error here http://www.esunsai.com/Tagserve5.jsp
Gerry Giese
Ranch Hand

Joined: Aug 02, 2001
Posts: 247
Apache is the webserver Tomcat uses. Tomcat is a servlet/JSP container. A webserver by itself does not have a servlet/JSP container and cannot execute Java code. A server with Tomcat properly configured will receive a request into the webserver, which determines (via URL patterns) if it can handle the request or if it needs to pass it on to Tomcat to handle. There are a few integrated web-server/servlet-conainer products, but the same basic process happens internally. If you are trying to deploy Java to a simple webserver, it will not work.


CJP (Certifiable Java Programmer), AMSE (Anti-Microsoft Software Engineer)
Author of Posts in the Saloon
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Taglib's not running