my dog learned polymorphism*
The moose likes JSP and the fly likes JSTL Requirements Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "JSTL Requirements" Watch "JSTL Requirements" New topic
Author

JSTL Requirements

Pradeep bhatt
Ranch Hand

Joined: Feb 27, 2002
Posts: 8919

Hi Java ranchers,
JSTL requires Servlet 2.3 and jsp 1.2 version. May I know the reason.
If true,this will be bad news for me becoz I cannot use it with Sun One web server used in my project.


Groovy
Shawn Bayern
Author
Ranch Hand

Joined: May 06, 2002
Posts: 160
Originally posted by Pradeep Bhat:
Hi Java ranchers,
JSTL requires Servlet 2.3 and jsp 1.2 version. May I know the reason.
If true,this will be bad news for me becoz I cannot use it with Sun One web server used in my project.

JSTL requires JSP 1.2 because it depends on some of JSP 1.2's new features. (This includes at least TagLibraryValidator, IterationTag, and a fuller specification of the tag-handler lifecycle protocol.)
You can use JSTL with the Web Services Developer Pack, with which it is bundled. You may also use it with Tomcat 4.x or any modern JSP 1.2 container. JSP 1.1 is shortly going to be two versions out of date, as JSP 2.0 is just around the corner.


Shawn Bayern<br />"JSTL in Action" <a href="http://www.jstlbook.com" target="_blank" rel="nofollow">http://www.jstlbook.com</a>
John Wetherbie
Rancher

Joined: Apr 05, 2000
Posts: 1449
Has any thought been given to retro-fitting JSTL to JSP 1.1? Or is this not worth the effort?


The only reason for time is so that everything doesn't happen all at once.
- Buckaroo Banzai
Shawn Bayern
Author
Ranch Hand

Joined: May 06, 2002
Posts: 160
Originally posted by John Wetherbie:
Has any thought been given to retro-fitting JSTL to JSP 1.1? Or is this not worth the effort?

Not really. It's mostly a matter of correctness and semantic expressiveness; JSP 1.1 simply doesn't support all the nuances that JSTL 1.0 relies on. Someone could always come up with a JSTL-like set of taglibs that runs on JSP 1.1, but it's not possible to implement JSTL 1.0 completely using JSP 1.1.
I also think you're right that even if it were possible, it might not be worth the effort. With JSP 2.0 just around the corner, JSP 1.1 is about to be two revisions behind. That doesn't mean it won't continue to be supported; all enterprise technologies are supported for quite a long time. It just means new features, like JSTL (and anything that JSP 2.0 brings to the table), need not be retrofitted to older versions of JSP.
 
Don't get me started about those stupid light bulbs.
 
subject: JSTL Requirements