File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JSP and the fly likes JSP gives correct display of japanese in IE but not in NC Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "JSP gives correct display of japanese in IE but not in NC" Watch "JSP gives correct display of japanese in IE but not in NC" New topic
Author

JSP gives correct display of japanese in IE but not in NC

yo nara
Ranch Hand

Joined: Apr 03, 2002
Posts: 35
hello
i have the following problem :
when i see the output of JSP page (which is in japanese )in IE i can see the japanese characters but when i see the same page in NC i can see only the '???' characters .
one solution to this problem is that if i add japanese language to the NC->Navigator->language i can see the correct page.
but even if i dont do this setting i can see the remaining pages correctly.the problem is to this page only.
i am pasting code of my page here some of the characters may not display correctly)
( my remaining pages are also in similar format)
<%@ page language="java"
import="java.util.*,
session="true"
contentType="text/html;
charset=Shift_JIS" %>
<%@ taglib prefix="c" uri="http://java.sun.com/jstl/core"%>
<%@ taglib prefix="c_rt" uri="http://java.sun.com/jstl/core_rt"%>
<%@ taglib prefix="fmt" uri="http://java.sun.com/jstl/fmt"%>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML>
<HEAD>
<TITLE>請求内訳検索</TITLE>
<jsp:include page="commonTitle.html" flush="false"/>
</HEAD>
<body class="bodyback" onContextMenu="javascript:return false;" >
<form method="POST" action="BillItemSearchServlet?<x ummy />">
--and some custom tags go here
</form>
</BODY>
</HTML>
one more thing i found is that if i make flush property of <jsp:include> tag true without changing the language setting i can see the japanese characters correctly in NC .but if i do so i get problem that if any exception occurs in my custom tags the error page is not displayed instead next page is shown with error in custom tag.
can any one help me to solve this problem.is it possible to do some change in code so that japanese characters are shown in NC correctly without setting the japanese language in settings of NC.or can any one give me the urls so that i can get any hint from there.
[ December 01, 2002: Message edited by: yogi naravane ]
Bhushan Jawle
Ranch Hand

Joined: Nov 22, 2001
Posts: 249
Hi Yogi,
Have you checked the encoding of the generated page when it shows '???' I would check that first to infer whether the encoding parameter is being ignored. It might not be the reason but al least will help eliminating the possiblities.
Thanks
Bhushan
yo nara
Ranch Hand

Joined: Apr 03, 2002
Posts: 35
the page gives correct encoding
it gives correct otput in IE also
and i have seen the source of other pages for encoding , which is same as this one.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JSP gives correct display of japanese in IE but not in NC