aspose file tools*
The moose likes JSP and the fly likes Servlet does not run Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "Servlet does not run" Watch "Servlet does not run" New topic
Author

Servlet does not run

Jianliang Xu
Greenhorn

Joined: Oct 27, 2002
Posts: 3
Hi, I am a greenhorn of Java. Please help me.
I am using Tomcat as my servlet container, and I create a web application under the directory of
"$TomcatHome$/webapp". All the Jsps run well, but when I put a servlet under "/WEB-INF/classes" and run it, I meet an error: "The requested resource (/jsp10/servlet/srv_intro) is not available".
I have specified the context for this web application in server.xml.
Waiting for your help.
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12683
    
    5
There have been a number of disucssions of similar problems in the servlets forum in the past week, all related to configuration in web.xml - browse the last week or so.
Bill
Jianliang Xu
Greenhorn

Joined: Oct 27, 2002
Posts: 3
Got it! Thanks for your help.
Jianliang Xu
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Servlet does not run
 
Similar Threads
Servlet error
Is running a servlet from the startup script possible
HTTP Status 404
Servlet not found exception
Unable to initialize Struts ActionServlet