Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
The moose likes JSP and the fly likes plz help.. ! is my JSP dead?? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "plz help.. ! is my JSP dead??" Watch "plz help.. ! is my JSP dead??" New topic
Author

plz help.. ! is my JSP dead??

Jack Daniel
Ranch Hand

Joined: Jun 15, 2002
Posts: 163
Hi e'body..
i'm getting sick of my problem.. can anybody give me an idea on what's happening..
I'm using VisualAge for java( a failure), as a testing tool..
maybe the JSP engine in VAJ is dead !!!
Till now,.. i have done quite a number of servlet/JSP(S) on my present project..
and in my new JSP, it just gives horrible error reports..
look at this:
(1)
<TD align="left" ><%= session.getAttribute("fullname") %></TD>
// from the compiled .java source
// ##DEBUG## C:\updatedtimes.jsp 44,39-C:\updatedtimes.jsp 44,73
out.print( session.getAttribute("fullname") );
it gives an error here as : Invalid escape character ( location of error is the space bar )
(2)
<TD align="left" ><%= session.getAttribute("startTime")%>
same error reporting... the location of error is ')'
there are a lot of such errors..
Everywhere in my JSP, i put an expression
<%= expression %> it gives an error saying INVALID escape character...
Whats going on???
I guess the problem is with the JSP engine in VAJ..!!!
Do you have any idea, why this is happening..
It would be Great, if anybody can help me on this..
Thanks a lot
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 29240
    
139

Try deleting the compiled jsp or reverting it back to a previous version that did compile. As you may have noticed, sometimes VAJ gets confused. It can't compile a new JSP because it is stuck on the old problems. This will not affect your real JSP.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
Jack Daniel
Ranch Hand

Joined: Jun 15, 2002
Posts: 163
Hey Jeanne ,
Thanks a lot.. for your reply..
I somehow,solved my problem.. i did try deleting the already compiled JSP.. deploying again-n-again ... neither worked... then i was thinking what to do..??
u know what solved the problem..?? hehe....
I just copied (crtl-C ) the same code and pasted into another JSP ( Ctrl-V ) and i made the correction in forwarding to this new JSP.. and there u go.. it worked... !!
I dunno why it was initially giving the problem..
but solved it this way..
Thanks, anyway
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: plz help.. ! is my JSP dead??
 
Similar Threads
Validate() method of ActionForm
LogonView.jsp Displays A Blank Page
HTML validation error: A form for each table row
Cannot retrieve mapping for action /content/AddLinks
session management problem with iframes