File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JSP and the fly likes Why can't I import these classes? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "Why can Watch "Why can New topic
Author

Why can't I import these classes?

Dominic Clarke
Greenhorn

Joined: Nov 12, 2003
Posts: 11
Hello Ranchpeople!

This is a jsp problem, but...................
My problem lies in the field of web services (I want to setup a simple web service), but I've fallen at the first hurdle when trying to use the Apache admin tool for deploying web services.
Basically, I'm using Tomcat to deploy my services, but whenever I try to access the deploy page (List.jsp), I'm greeted with this error:

org.apache.jasper.JasperException: Unable to compile class for JSP
An error occurred at line: 4 in the jsp file: /admin/list.jsp
Generated servlet error:
[javac] Compiling 1 source file
C:\Tomcat 4.1\work\Standalone\localhost\soap\admin\list_jsp.java:8: cannot resolve symbol
symbol : class Constants
location: package soap
import org.apache.soap.Constants;
^
C:\Tomcat 4.1\work\Standalone\localhost\soap\admin\list_jsp.java:9: package org.apache.soap.server does not exist
import org.apache.soap.server.*;
^
C:\Tomcat 4.1\work\Standalone\localhost\soap\admin\list_jsp.java:48: cannot resolve symbol
symbol : variable Constants
location: class org.apache.jsp.list_jsp
String configFilename = config.getInitParameter(Constants.CONFIGFILENAME);
.......etc........etc..............
So, basically, it's having problems importing "org.apache.soap.Constants", and "org.apache.soap.server.*", and I don't know why this is!!!
I've tried puuting these classes into my Tomcat directory, in my J2EE/lib directory, setting CLASSPATH's so they point to these classes, but still it wont work! (Ihave tried EVERYTHING I can think of)
Would it have anything to do with web.xml maybe?
Can anybody give me some help, because it's driving me nuts......

Thanks
Dominic Clarke
Greenhorn

Joined: Nov 12, 2003
Posts: 11
Sorry to bump this up but can anyone help me?
Please?
damien malone
Ranch Hand

Joined: May 06, 2003
Posts: 35
Hi Dominic
Try copying the jar files into the projects lib directory off the WEB-INF folder, so for a project called myProj the directory would be
webapps\myProj\WEB-INF\lib
off the tomcat home directory
Hope that helps
Damien
Dominic Clarke
Greenhorn

Joined: Nov 12, 2003
Posts: 11
Thanks for the help, but it hasn't worked. :-(
I've been trying this for FIVE days now.
Roger Graff
Ranch Hand

Joined: May 29, 2001
Posts: 112
Pehaps the fact that you have a space in your root directory is causing a problem:
C:\Tomcat 4.1
Try naming the dir to C:\Tomcat_4.1
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Why can't I import these classes?