aspose file tools*
The moose likes JSP and the fly likes javascript not working, please help me out Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "javascript not working, please help me out" Watch "javascript not working, please help me out" New topic
Author

javascript not working, please help me out

svr
Greenhorn

Joined: Jan 06, 2004
Posts: 8
Hello,
I am using netbeans3.3.2 for java and jsp coding. Tomcat3.2 as server. I have used javascript validation in JSP. There is no error in my javascript coding. But I have identified that the problem is with jsp compilation. I have stored the JSPs in a folder named JSP instead of WEB-INF. When I right click the JSP folder , an option is there ' Build ALL', when I click Build All only the HTML code in jsp is changing , the javascript is not working. But when I compile mere the jsp I am working . it doesn't show any change. It changes only when I give the Build All !
I couldn't identify what the problem is ! Is this a problem with netbeans settings or the tomcat? !
Hope this is a clear explanation. Please feel free to ask any questions.
Thanks
Eric Pascarello
author
Rancher

Joined: Nov 08, 2001
Posts: 15376
    
    6
Please do not cross post. I am going to leave this one here since it applies here more then other in HTML and JavaScript.
svr
Greenhorn

Joined: Jan 06, 2004
Posts: 8
ok, thanks, now its working !
but it submits the form after clicking the OK of alert !
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61756
    
  67

Welcome to the Ranch svr!
You'll find this forum a great place to seek help on JSP pages, and there aren't many rules you'll have to worry about, but one is that proper names are required. Please take a look at the JavaRanch Naming Policy and change your display name to match it.
In particular, your display name must be a first and a last name separated by a space character, and must not be obviously fictitious.
Thanks!
bear
JSP Forum Bartender
[ January 06, 2004: Message edited by: Bear Bibeault ]

[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61756
    
  67

Now as to your last question:
but it submits the form after clicking the OK of alert !

Since this is unrelated to your original question, it's best to start a new topic for new questions. And this one, in fact, probably belongs in the HTML/Javascript forum rather than here in JSP -- and with a lot more details as to what problem you are having. (But as Eric pointed out, you should pick one forum to post your question in. Please do not cross-post the same question in more than one forum).
bear
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: javascript not working, please help me out