Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

j_security_check question

 
Eric Bic
Greenhorn
Posts: 7
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Im new to Tomcat and Jsp and im trying to get a simple login jsp page to work, well i was trying to make the Login page example provided by the Java web services tutorial and when i try to login (taking me then either to the error page or Hello page) i get a page with the following information
HTTP Status 404 - /jwstutorial13/examples/security/login/web/j_security_check
--------------------------------------------------------------------------------
type Status report
message /jwstutorial13/examples/security/login/web/j_security_check
description The requested resource (/jwstutorial13/examples/security/login/web/j_security_check) is not available.

im not sure what this means, anyone have any ideas
Thanks in advance
Eric
 
Tim Holloway
Saloon Keeper
Pie
Posts: 17626
39
Android Eclipse IDE Linux
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You're probably giving a URL of "login.jsp" when you try and access the site. That's not how it works. Just access a security-managed page and the login.jsp will automatically be displayed in its proper context.
 
Eric Bic
Greenhorn
Posts: 7
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i feel like such a dummy i dont even know what you mean by that, ive put all the jsp files in the Root directory under the Webapps folder. And im opening the file through my web browser but just typing in
http://localhost:8080/jwstutorial13/examples/security/login
when i try to login with one of the users i have added to the tomcat-users.xml file. which looks like this right now:
<?xml version='1.0' encoding='utf-8'?>
<tomcat-users>
<role rolename="loginUser"/>
<role rolename="user" description="Cannot add/delete users"/>
<role rolename="manager"/>
<role rolename="admin"/>
<user username="eric" password="eric" fullName="Eric" roles="admin,manager,user,loginUser"/>
</tomcat-users>
if gives me the error above, is there anything i should change in the web.xml file? im not sure how to edit that.
im so lost
[ April 12, 2004: Message edited by: eric bichara ]
 
Eric Bic
Greenhorn
Posts: 7
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is there anyone that has done with tutorial or has an idea what the problem may be? or any tips on what i should read up on to better understand the problem, all i want to do is create a simple login procedure for my webpage, is there an easier way to do this?
thanks for your help
Eric
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic